CVE-2024-13041 Incorrect User Management in GitLab

Medium 4.2 Published Updated

Attackers can bypass external user restrictions via SAML group settings to access internal projects, requiring GitLab administrators to upgrade.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2024-13041?

CVE-2024-13041 is a medium-severity authentication bypass vulnerability in Gitlab Gitlab, published on 9 Jan 2025. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

An issue was discovered in GitLab CE/EE affecting all versions starting from 16.4 prior to 17.5.5, starting from 17.6 prior to 17.6.3, and starting from 17.7 prior to 17.7.1. When a user is created via the SAML provider, the external groups setting overrides the external provider configuration. As a result, the user may not be marked as external thereby giving those users access to internal projects or groups.

Weakness: CWE-286

Which versions are affected by CVE-2024-13041?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiFrom 16.4.017.5.5, 17.6.3, 17.7.1

Products include Gitlab Gitlab.

How do I fix CVE-2024-13041?

Upgrade gitlab to a fixed version for your release line: 17.5.5, 17.6.3 or 17.7.1.

Upgrade, and rotate credentials and sessions that may have been exposed. More about Authentication bypass.

Is CVE-2024-13041 being exploited?

There is no known exploitation of CVE-2024-13041 in the wild and no public exploit code.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2024-13041, GHSA-j94v-jxmv-27r2, UBUNTU-CVE-2024-13041.

Is CVE-2024-13041 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free