CVE-2024-13129 Roxy-WI roxy.py action_service os command injection

High 8.7 Published Updated

Remote attackers with permissions can execute arbitrary OS commands via the action_service function in Roxy-WI.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
None listed

What is CVE-2024-13129?

CVE-2024-13129 is a high-severity command injection vulnerability in Roxy-WI, published on 3 Jan 2025. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

A vulnerability was found in Roxy-WI up to 8.1.3. It has been declared as critical. Affected by this vulnerability is the function action_service of the file app/modules/roxywi/roxy.py. The manipulation of the argument action/service leads to os command injection. The attack can be launched remotely. The exploit has been disclosed to the public and may be used. Upgrading to version 8.1.4 is able to address this issue. The identifier of the patch is 32313928eb9ce906887b8a30bf7b9a3d5c0de1be. It is recommended to upgrade the affected component.

Weakness: CWE-78, CWE-77

Which versions are affected by CVE-2024-13129?

How do I fix CVE-2024-13129?

No fix has been published for CVE-2024-13129 yet. Limit exposure of the affected software until one is available.

Upgrade, and pass arguments to programs as a list instead of through a shell. More about Command injection.

Is CVE-2024-13129 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-13129 exists.

Sources

Also known as GHSA-2f7r-82r8-4h2g.

Is CVE-2024-13129 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free