{"answers":{"affected":"","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-13129 exists.","fix":"No fix has been published for CVE-2024-13129 yet. Limit exposure of the affected software until one is available.","what":"CVE-2024-13129 is a high-severity command injection vulnerability in Roxy-WI, published on 3 Jan 2025. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-13129 and fix it if it is affected.\n\nWhat it is: CVE-2024-13129 is a high-severity command injection vulnerability in Roxy-WI, published on 3 Jan 2025. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-13129 exists.\n\nAffected product: Roxy-WI. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-13129/ (Markdown: https://insights.sbomify.com/CVE-2024-13129/index.md)","id":"CVE-2024-13129","markdown":"https://insights.sbomify.com/CVE-2024-13129/index.md","name":"CVE-2024-13129","record":{"aliases":["GHSA-2f7r-82r8-4h2g"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Roxy-WI","requires_auth":"low_privilege","summary":"Remote attackers with permissions can execute arbitrary OS commands via the action_service function in Roxy-WI.","user_interaction":"not_required","vuln_class":"command_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulDB","cpe":[],"cvss":{"score":8.7,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-78","name":"Improper Neutralization of Special Elements used in an OS Command"},{"id":"CWE-77","name":"Improper Neutralization of Special Elements used in a Command"}],"description":"A vulnerability was found in Roxy-WI up to 8.1.3. It has been declared as critical. Affected by this vulnerability is the function action_service of the file app/modules/roxywi/roxy.py. The manipulation of the argument action/service leads to os command injection. The attack can be launched remotely. The exploit has been disclosed to the public and may be used. Upgrading to version 8.1.4 is able to address this issue. The identifier of the patch is 32313928eb9ce906887b8a30bf7b9a3d5c0de1be. It is recommended to upgrade the affected component.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":false,"headline":"Roxy-WI roxy.py action_service os command injection","id":"CVE-2024-13129","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"command_injection","year":"2024"},"n_packages":0,"n_references":8,"next":{"headline":"Dahua IPC-HFW1200S Web Interface Sha1Account1 path traversal","id":"CVE-2024-13130"},"packages":[],"prev":{"headline":"LearnPress – WordPress LMS Plugin \u003c 4.2.7.5.1 - Admin+ Stored XSS","id":"CVE-2024-13128"},"products":["Roxy-WI"],"published":"2025-01-03","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-08-28","vendors":["n/a"]},"summary":"Remote attackers with permissions can execute arbitrary OS commands via the action_service function in Roxy-WI.","url":"https://insights.sbomify.com/CVE-2024-13129/"}