{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2024-13238 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2024-13238 is a medium-severity cross-site scripting vulnerability in Drupal Typogrify, published on 9 Jan 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2024-13238 and fix it if it is affected.\n\nWhat it is: CVE-2024-13238 is a medium-severity cross-site scripting vulnerability in Drupal Typogrify, published on 9 Jan 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2024-13238 in the wild and no public exploit code.\n\nAffected product: Drupal Typogrify. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-13238/ (Markdown: https://insights.sbomify.com/CVE-2024-13238/index.md)","id":"CVE-2024-13238","markdown":"https://insights.sbomify.com/CVE-2024-13238/index.md","name":"CVE-2024-13238","record":{"aliases":["DRUPAL-CONTRIB-2024-002","GHSA-vxch-vvvr-4v8f","MINI-c2p7-p9h7-3672"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Drupal Typogrify module","requires_auth":"low_privilege","summary":"An attacker can inject malicious scripts into web pages viewed by other users via the Typogrify module, potentially leading to session hijacking or data theft.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"drupal","cpe":[{"product":"typogrify","vendor":"typogrify_project"}],"cvss":{"score":5.4,"severity":"medium","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Drupal Typogrify allows Cross-Site Scripting (XSS).This issue affects Typogrify: from 0.0.0 before 1.3.0.","ecosystems":["Packagist:https://packages.drupal.org/8"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Typogrify - Moderately critical - Cross Site Scripting - SA-CONTRIB-2024-002","id":"CVE-2024-13238","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"xss","year":"2024"},"n_packages":1,"n_references":1,"next":{"headline":"Two-factor Authentication (TFA) - Moderately critical - Access bypass - SA-CONTRIB-2024-003","id":"CVE-2024-13239"},"packages":[{"ecosystem":"Packagist:https://packages.drupal.org/8","fixed":["1.3.0"],"introduced":["0"],"last_affected":[],"package":"drupal/typogrify","purl":"pkg:composer/drupal/typogrify?repository_url=https:%2F%2Fpackages.drupal.org%2F8","source":"DRUPAL-CONTRIB-2024-002"}],"prev":{"headline":"File Entity (fieldable files) - Moderately critical - Cross Site Scripting, Access bypass - SA-CONTRIB-2024-001","id":"CVE-2024-13237"},"products":["Typogrify"],"published":"2025-01-09","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"MIT","name":"Drupal","prefix":"DRUPAL"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-01-09","vendors":["Drupal"]},"summary":"An attacker can inject malicious scripts into web pages viewed by other users via the Typogrify module, potentially leading to session hijacking or data theft.","url":"https://insights.sbomify.com/CVE-2024-13238/"}