{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2024-13244 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2024-13244 is a high-severity vulnerability in Drupal Migrate Tools, published on 9 Jan 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2024-13244 and fix it if it is affected.\n\nWhat it is: CVE-2024-13244 is a high-severity vulnerability in Drupal Migrate Tools, published on 9 Jan 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2024-13244 in the wild and no public exploit code.\n\nAffected product: Drupal Migrate Tools. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-13244/ (Markdown: https://insights.sbomify.com/CVE-2024-13244/index.md)","id":"CVE-2024-13244","markdown":"https://insights.sbomify.com/CVE-2024-13244/index.md","name":"CVE-2024-13244","record":{"aliases":["DRUPAL-CONTRIB-2024-008","GHSA-j6c4-8pwx-h3g3"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Drupal Migrate Tools","requires_auth":"none","summary":"Attackers can trick authenticated users into performing unintended actions in the Drupal Migrate Tools module via CSRF.","user_interaction":"required","vuln_class":"csrf"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"drupal","cpe":[{"product":"migrate_tools","vendor":"migrate_tools_project"}],"cvss":{"score":8.8,"severity":"high","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-352","name":"Cross-Site Request Forgery"}],"description":"Cross-Site Request Forgery (CSRF) vulnerability in Drupal Migrate Tools allows Cross Site Request Forgery.This issue affects Migrate Tools: from 0.0.0 before 6.0.3.","ecosystems":["Packagist:https://packages.drupal.org/8"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Migrate Tools - Moderately critical - Cross Site Request Forgery - SA-CONTRIB-2024-008","id":"CVE-2024-13244","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"csrf","year":"2024"},"n_packages":1,"n_references":1,"next":{"headline":"CKEditor 4 LTS - WYSIWYG HTML editor - Moderately critical - Cross Site Scripting - SA-CONTRIB-2024-009","id":"CVE-2024-13245"},"packages":[{"ecosystem":"Packagist:https://packages.drupal.org/8","fixed":["6.0.3"],"introduced":["0"],"last_affected":[],"package":"drupal/migrate_tools","purl":"pkg:composer/drupal/migrate_tools?repository_url=https:%2F%2Fpackages.drupal.org%2F8","source":"DRUPAL-CONTRIB-2024-008"}],"prev":{"headline":"Entity Delete Log - Moderately critical - Access bypass - SA-CONTRIB-2024-007","id":"CVE-2024-13243"},"products":["Migrate Tools"],"published":"2025-01-09","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"MIT","name":"Drupal","prefix":"DRUPAL"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-01-10","vendors":["Drupal"]},"summary":"Attackers can trick authenticated users into performing unintended actions in the Drupal Migrate Tools module via CSRF.","url":"https://insights.sbomify.com/CVE-2024-13244/"}