{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2024-13245 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2024-13245 is a medium-severity cross-site scripting vulnerability in Drupal CKEditor 4 LTS - WYSIWYG HTML editor, published on 9 Jan 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2024-13245 and fix it if it is affected.\n\nWhat it is: CVE-2024-13245 is a medium-severity cross-site scripting vulnerability in Drupal CKEditor 4 LTS - WYSIWYG HTML editor, published on 9 Jan 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2024-13245 in the wild and no public exploit code.\n\nAffected product: Drupal CKEditor 4 LTS - WYSIWYG HTML editor. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-13245/ (Markdown: https://insights.sbomify.com/CVE-2024-13245/index.md)","id":"CVE-2024-13245","markdown":"https://insights.sbomify.com/CVE-2024-13245/index.md","name":"CVE-2024-13245","record":{"aliases":["DRUPAL-CONTRIB-2024-009","GHSA-2gj6-558v-rq2w"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Drupal CKEditor plugin","requires_auth":"low_privilege","summary":"An attacker can inject malicious scripts into web pages via the CKEditor 4 LTS plugin in Drupal, potentially compromising user sessions.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"drupal","cpe":[{"product":"ckeditor_4","vendor":"cksource"}],"cvss":{"score":5.4,"severity":"medium","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Drupal CKEditor 4 LTS - WYSIWYG HTML editor allows Cross-Site Scripting (XSS).This issue affects CKEditor 4 LTS - WYSIWYG HTML editor: from 1.0.0 before 1.0.1.","ecosystems":["Packagist:https://packages.drupal.org/8"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"CKEditor 4 LTS - WYSIWYG HTML editor - Moderately critical - Cross Site Scripting - SA-CONTRIB-2024-009","id":"CVE-2024-13245","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"xss","year":"2024"},"n_packages":1,"n_references":1,"next":{"headline":"Node Access Rebuild Progressive - Less critical - Access bypass - SA-CONTRIB-2024-010","id":"CVE-2024-13246"},"packages":[{"ecosystem":"Packagist:https://packages.drupal.org/8","fixed":["1.0.1"],"introduced":["1.0.0"],"last_affected":[],"package":"drupal/ckeditor_lts","purl":"pkg:composer/drupal/ckeditor_lts?repository_url=https:%2F%2Fpackages.drupal.org%2F8","source":"DRUPAL-CONTRIB-2024-009"}],"prev":{"headline":"Migrate Tools - Moderately critical - Cross Site Request Forgery - SA-CONTRIB-2024-008","id":"CVE-2024-13244"},"products":["CKEditor 4 LTS - WYSIWYG HTML editor"],"published":"2025-01-09","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"MIT","name":"Drupal","prefix":"DRUPAL"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-01-09","vendors":["Drupal"]},"summary":"An attacker can inject malicious scripts into web pages via the CKEditor 4 LTS plugin in Drupal, potentially compromising user sessions.","url":"https://insights.sbomify.com/CVE-2024-13245/"}