{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2024-13264 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2024-13264 is a critical code injection vulnerability in Drupal Opigno module, published on 9 Jan 2025. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-13264 and fix it if it is affected.\n\nWhat it is: CVE-2024-13264 is a critical code injection vulnerability in Drupal Opigno module, published on 9 Jan 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2024-13264 in the wild and no public exploit code.\n\nAffected product: Drupal Opigno module. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-13264/ (Markdown: https://insights.sbomify.com/CVE-2024-13264/index.md)","id":"CVE-2024-13264","markdown":"https://insights.sbomify.com/CVE-2024-13264/index.md","name":"CVE-2024-13264","record":{"aliases":["DRUPAL-CONTRIB-2024-028","GHSA-99h6-9pr2-5g94"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Drupal Opigno module","requires_auth":"none","summary":"Attackers can execute arbitrary PHP code via static code injection in the Drupal Opigno module, requiring an upgrade to mitigate.","user_interaction":"not_required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"drupal","cpe":[{"product":"opigno_module","vendor":"opigno"}],"cvss":{"score":9.8,"severity":"critical","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-96","name":"Improper Neutralization of Directives in Statically Saved Code"}],"description":"Improper Neutralization of Directives in Statically Saved Code ('Static Code Injection') vulnerability in Drupal Opigno module allows PHP Local File Inclusion.This issue affects Opigno module: from 0.0.0 before 3.1.2.","ecosystems":["Packagist:https://packages.drupal.org/8"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Opigno module - Critical - Arbitrary PHP code execution - SA-CONTRIB-2024-028","id":"CVE-2024-13264","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"code_injection","year":"2024"},"n_packages":1,"n_references":1,"next":{"headline":"Opigno Learning path - Critical - Arbitrary PHP code execution - SA-CONTRIB-2024-029","id":"CVE-2024-13265"},"packages":[{"ecosystem":"Packagist:https://packages.drupal.org/8","fixed":["3.1.2"],"introduced":["0"],"last_affected":[],"package":"drupal/opigno_module","purl":"pkg:composer/drupal/opigno_module?repository_url=https:%2F%2Fpackages.drupal.org%2F8","source":"DRUPAL-CONTRIB-2024-028"}],"prev":{"headline":"Opigno group manager - Critical - Arbitrary PHP code execution - SA-CONTRIB-2024-027","id":"CVE-2024-13263"},"products":["Opigno module"],"published":"2025-01-09","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"MIT","name":"Drupal","prefix":"DRUPAL"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-01-10","vendors":["Drupal"]},"summary":"Attackers can execute arbitrary PHP code via static code injection in the Drupal Opigno module, requiring an upgrade to mitigate.","url":"https://insights.sbomify.com/CVE-2024-13264/"}