# CVE-2024-13274: Open Social - Moderately critical - Denial of Service - SA-CONTRIB-2024-038

> Attackers can cause denial of service in Drupal Open Social by exploiting improper control of interaction frequency.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 9 Jan 2025
- **Updated:** 14 Jan 2025
- **Also known as:** GHSA-63wg-87qv-rw4r

## What is CVE-2024-13274?

CVE-2024-13274 is a medium-severity denial of service vulnerability in Drupal Open Social, published on 9 Jan 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Improper Control of Interaction Frequency vulnerability in Drupal Open Social allows Functionality Misuse.This issue affects Open Social: from 0.0.0 before 12.3.8, from 12.4.0 before 12.4.5.

Weakness: CWE-799 (Improper Control of Interaction Frequency)

## Which versions are affected by CVE-2024-13274?

6 open source packages ship an affected version, including goalgorilla/open_social. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `goalgorilla/open_social` | Packagist | All versions | 12.3.8 |
| `goalgorilla/open_social` | Packagist | All versions | 12.3.8 |
| `goalgorilla/open_social` | Packagist | From 12.4.0 | 12.4.5 |
| `goalgorilla/open_social` | Packagist | From 12.4.0 | 12.4.5 |
| `goalgorilla/open_social` | Packagist | From 13.0.0-alpha1 | 13.0.0-alpha11 |
| `goalgorilla/open_social` | Packagist | From 13.0.0-alpha1 | 13.0.0-alpha11 |

Products: Getopensocial Open Social.

## How do I fix CVE-2024-13274?

Upgrade goalgorilla/open_social to a fixed version for your release line: 12.3.8, 12.4.5 or 13.0.0-alpha11.

## Is CVE-2024-13274 being exploited?

There is no known exploitation of CVE-2024-13274 in the wild and no public exploit code.

## Other vulnerabilities in Drupal Open Social

- [CVE-2025-31685](https://insights.sbomify.com/CVE-2025-31685/): Open Social - Moderately critical - Access bypass - SA-CONTRIB-2025-014 (critical 9.1)
- [CVE-2024-13241](https://insights.sbomify.com/CVE-2024-13241/): Open Social - Moderately critical - Information Disclosure - SA-CONTRIB-2024-005 (critical 9.1)
- [CVE-2025-48921](https://insights.sbomify.com/CVE-2025-48921/): Open Social - Moderately critical - Cross Site Request Forgery - SA-CONTRIB-2025-079 (high 8.8)
- [CVE-2025-31686](https://insights.sbomify.com/CVE-2025-31686/): Open Social - Less critical - Access bypass, Information Disclosure - SA-CONTRIB-2025-015 (high 8.1)
- [CVE-2024-13240](https://insights.sbomify.com/CVE-2024-13240/): Open Social - Moderately critical - Access bypass - SA-CONTRIB-2024-004 (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-13274 and fix it if it is affected.

What it is: CVE-2024-13274 is a medium-severity denial of service vulnerability in Drupal Open Social, published on 9 Jan 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-13274 in the wild and no public exploit code.

Affected packages and fixed versions:
- goalgorilla/open_social (Packagist): affected all versions; fixed in 12.3.8
- goalgorilla/open_social (Packagist): affected all versions; fixed in 12.3.8
- goalgorilla/open_social (Packagist): affected from 12.4.0; fixed in 12.4.5
- goalgorilla/open_social (Packagist): affected from 12.4.0; fixed in 12.4.5
- goalgorilla/open_social (Packagist): affected from 13.0.0-alpha1; fixed in 13.0.0-alpha11
- goalgorilla/open_social (Packagist): affected from 13.0.0-alpha1; fixed in 13.0.0-alpha11

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-13274/ (Markdown: https://insights.sbomify.com/CVE-2024-13274/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-13274
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-13274
- OSV: https://osv.dev/vulnerability/CVE-2024-13274

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-13274/
Summaries are generated and may contain mistakes; the official description above is the record.
