{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2024-13275 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2024-13275 is a medium-severity denial of service vulnerability in Drupal Security Kit, published on 9 Jan 2025. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-13275 and fix it if it is affected.\n\nWhat it is: CVE-2024-13275 is a medium-severity denial of service vulnerability in Drupal Security Kit, published on 9 Jan 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2024-13275 in the wild and no public exploit code.\n\nAffected product: Drupal Security Kit. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-13275/ (Markdown: https://insights.sbomify.com/CVE-2024-13275/index.md)","id":"CVE-2024-13275","markdown":"https://insights.sbomify.com/CVE-2024-13275/index.md","name":"CVE-2024-13275","record":{"aliases":["DRUPAL-CONTRIB-2024-039","GHSA-jjvf-4cxj-rqv4"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Drupal Security Kit","requires_auth":"none","summary":"An attacker can cause a denial of service in Drupal sites using the Security Kit module due to a type confusion vulnerability.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"drupal","cpe":[{"product":"security_kit","vendor":"security_kit_project"}],"cvss":{"score":5.3,"severity":"medium","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L","version":"3.1"},"cwes":[{"id":"CWE-843","name":"Access of Resource Using Incompatible Type"}],"description":"Access of Resource Using Incompatible Type ('Type Confusion') vulnerability in Drupal Security Kit allows HTTP DoS.This issue affects Security Kit: from 0.0.0 before 2.0.3.","ecosystems":["Packagist:https://packages.drupal.org/8"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Security Kit - Less critical - Denial of Service - SA-CONTRIB-2024-039","id":"CVE-2024-13275","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"denial_of_service","year":"2024"},"n_packages":1,"n_references":1,"next":{"headline":"File Entity (fieldable files) - Moderately critical - Information Disclosure - SA-CONTRIB-2024-040","id":"CVE-2024-13276"},"packages":[{"ecosystem":"Packagist:https://packages.drupal.org/8","fixed":["2.0.3"],"introduced":["0"],"last_affected":[],"package":"drupal/seckit","purl":"pkg:composer/drupal/seckit?repository_url=https:%2F%2Fpackages.drupal.org%2F8","source":"DRUPAL-CONTRIB-2024-039"}],"prev":{"headline":"Open Social - Moderately critical - Denial of Service - SA-CONTRIB-2024-038","id":"CVE-2024-13274"},"products":["Security Kit"],"published":"2025-01-09","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"MIT","name":"Drupal","prefix":"DRUPAL"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-01-14","vendors":["Drupal"]},"summary":"An attacker can cause a denial of service in Drupal sites using the Security Kit module due to a type confusion vulnerability.","url":"https://insights.sbomify.com/CVE-2024-13275/"}