{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2024-13280 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2024-13280 is a critical authentication bypass vulnerability in Drupal Persistent Login, published on 9 Jan 2025. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-13280 and fix it if it is affected.\n\nWhat it is: CVE-2024-13280 is a critical authentication bypass vulnerability in Drupal Persistent Login, published on 9 Jan 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2024-13280 in the wild and no public exploit code.\n\nAffected product: Drupal Persistent Login. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-13280/ (Markdown: https://insights.sbomify.com/CVE-2024-13280/index.md)","id":"CVE-2024-13280","markdown":"https://insights.sbomify.com/CVE-2024-13280/index.md","name":"CVE-2024-13280","record":{"aliases":["DRUPAL-CONTRIB-2024-044","GHSA-9q24-c9h6-h244"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"Drupal Persistent Login","requires_auth":"none","summary":"Attackers can bypass session expiration to maintain unauthorized access to user accounts in the Drupal Persistent Login module.","user_interaction":"not_required","vuln_class":"auth_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"drupal","cpe":[{"product":"persistent_login","vendor":"persistent_login_project"}],"cvss":{"score":9.8,"severity":"critical","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-613","name":"DEPRECATED: Insufficient Session Expiration"}],"description":"Insufficient Session Expiration vulnerability in Drupal Persistent Login allows Forceful Browsing.This issue affects Persistent Login: from 0.0.0 before 1.8.0, from 2.0.* before 2.2.2.","ecosystems":["Packagist:https://packages.drupal.org/8"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Persistent Login - Moderately critical - Access bypass - SA-CONTRIB-2024-044","id":"CVE-2024-13280","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"auth_bypass","year":"2024"},"n_packages":1,"n_references":1,"next":{"headline":"Monster Menus - Moderately critical - Access bypass, Information Disclosure - SA-CONTRIB-2024-045","id":"CVE-2024-13281"},"packages":[{"ecosystem":"Packagist:https://packages.drupal.org/8","fixed":["1.8.0","2.2.2","2.1.0","2.2.0"],"introduced":["0","2.2.0","2.0.0","2.1.0"],"last_affected":[],"package":"drupal/persistent_login","purl":"pkg:composer/drupal/persistent_login?repository_url=https:%2F%2Fpackages.drupal.org%2F8","source":"DRUPAL-CONTRIB-2024-044"}],"prev":{"headline":"Two-factor Authentication (TFA) - Critical - Access bypass - SA-CONTRIB-2024-043","id":"CVE-2024-13279"},"products":["Persistent Login"],"published":"2025-01-09","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"MIT","name":"Drupal","prefix":"DRUPAL"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-01-10","vendors":["Drupal"]},"summary":"Attackers can bypass session expiration to maintain unauthorized access to user accounts in the Drupal Persistent Login module.","url":"https://insights.sbomify.com/CVE-2024-13280/"}