# CVE-2024-1329: Nomad Vulnerable to Arbitrary Write Through Symlink Attack

> Attackers can write arbitrary files on the host via symlink attacks in the template renderer, potentially escalating privileges.

- **Severity:** High 7.7 (`CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:C/C:N/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 8 Feb 2024
- **Updated:** 26 Sep 2024
- **Also known as:** GHSA-c866-8gpw-p3mv, GO-2024-2538, UBUNTU-CVE-2024-1329

## What is CVE-2024-1329?

CVE-2024-1329 is a high-severity path traversal vulnerability in HashiCorp Nomad, published on 8 Feb 2024. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

HashiCorp Nomad and Nomad Enterprise 1.5.13 up to 1.6.6, and 1.7.3 template renderer is vulnerable to arbitrary file write on the host as the Nomad client user through symlink attacks. This vulnerability, CVE-2024-1329, is fixed in Nomad 1.7.4, 1.6.7, and 1.5.14.

Weakness: CWE-610 (Externally Controlled Reference to a Resource in Another Sphere), CWE-59 (Improper Link Resolution Before File Access)

## Which versions are affected by CVE-2024-1329?

7 open source packages ship an affected version, including github.com/hashicorp/nomad. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/hashicorp/nomad` | Go | From 1.5.13 | 1.5.14, 1.6.7, 1.7.4 |
| `github.com/hashicorp/nomad` | Go | From 1.5.13 | 1.5.14 |
| `github.com/hashicorp/nomad` | Go | From 1.5.13 | 1.5.14 |
| `github.com/hashicorp/nomad` | Go | From 1.6.0 | 1.6.7 |
| `github.com/hashicorp/nomad` | Go | From 1.6.0 | 1.6.7 |
| `github.com/hashicorp/nomad` | Go | From 1.7.3 | 1.7.4 |
| `github.com/hashicorp/nomad` | Go | From 1.7.3 | 1.7.4 |

Products: Hashicorp Nomad.

## How do I fix CVE-2024-1329?

Upgrade github.com/hashicorp/nomad to a fixed version for your release line: 1.5.14, 1.6.7 or 1.7.4.

## Is CVE-2024-1329 being exploited?

There is no known exploitation of CVE-2024-1329 in the wild and no public exploit code.

## Other vulnerabilities in HashiCorp Nomad

- [CVE-2023-1782](https://insights.sbomify.com/CVE-2023-1782/): Nomad Unauthenticated Client Agent HTTP Request Privilege Escalation (critical 10.0)
- [CVE-2022-30324](https://insights.sbomify.com/CVE-2022-30324/): Privilege escalation in Hashicorp Nomad (critical 9.8)
- [CVE-2020-7956](https://insights.sbomify.com/CVE-2020-7956/): Improper Certificate Validation in HashiCorp Nomad (critical 9.8)
- [CVE-2019-12618](https://insights.sbomify.com/CVE-2019-12618/): Hashicorp Nomad Access Control Issues (critical 9.8)
- [CVE-2020-27195](https://insights.sbomify.com/CVE-2020-27195/): Use After Free in HashiCorp Nomad (critical 9.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-1329 and fix it if it is affected.

What it is: CVE-2024-1329 is a high-severity path traversal vulnerability in HashiCorp Nomad, published on 8 Feb 2024. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-1329 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/hashicorp/nomad (Go): affected from 1.5.13; fixed in 1.5.14, 1.6.7, 1.7.4
- github.com/hashicorp/nomad (Go): affected from 1.5.13; fixed in 1.5.14
- github.com/hashicorp/nomad (Go): affected from 1.5.13; fixed in 1.5.14
- github.com/hashicorp/nomad (Go): affected from 1.6.0; fixed in 1.6.7
- github.com/hashicorp/nomad (Go): affected from 1.6.0; fixed in 1.6.7
- github.com/hashicorp/nomad (Go): affected from 1.7.3; fixed in 1.7.4
- github.com/hashicorp/nomad (Go): affected from 1.7.3; fixed in 1.7.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-1329/ (Markdown: https://insights.sbomify.com/CVE-2024-1329/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-1329
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-1329
- OSV: https://osv.dev/vulnerability/CVE-2024-1329

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-1329/
Summaries are generated and may contain mistakes; the official description above is the record.
