{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2024-13294 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2024-13294 is a medium-severity cross-site scripting vulnerability in Drupal POST File, published on 9 Jan 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2024-13294 and fix it if it is affected.\n\nWhat it is: CVE-2024-13294 is a medium-severity cross-site scripting vulnerability in Drupal POST File, published on 9 Jan 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2024-13294 in the wild and no public exploit code.\n\nAffected product: Drupal POST File. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-13294/ (Markdown: https://insights.sbomify.com/CVE-2024-13294/index.md)","id":"CVE-2024-13294","markdown":"https://insights.sbomify.com/CVE-2024-13294/index.md","name":"CVE-2024-13294","record":{"aliases":["DRUPAL-CONTRIB-2024-060","GHSA-9838-cxcw-r6rf"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["code_execution","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Drupal POST File module","requires_auth":"low_privilege","summary":"Attackers can execute arbitrary PHP code and scripts via XSS in the Drupal POST File module, compromising site integrity.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"drupal","cpe":[{"product":"post_file","vendor":"post_file_project"}],"cvss":{"score":5.4,"severity":"medium","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Drupal POST File allows Cross-Site Scripting (XSS).This issue affects POST File: from 0.0.0 before 1.0.2.","ecosystems":["Packagist:https://packages.drupal.org/8"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"POST File - Critical - Cross Site Scripting, Arbitrary PHP code execution - SA-CONTRIB-2024-060","id":"CVE-2024-13294","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"xss","year":"2024"},"n_packages":1,"n_references":1,"next":{"headline":"Node export - Moderately critical - Arbitrary PHP code execution - SA-CONTRIB-2024-061","id":"CVE-2024-13295"},"packages":[{"ecosystem":"Packagist:https://packages.drupal.org/8","fixed":["1.0.2"],"introduced":["0"],"last_affected":[],"package":"drupal/postfile","purl":"pkg:composer/drupal/postfile?repository_url=https:%2F%2Fpackages.drupal.org%2F8","source":"DRUPAL-CONTRIB-2024-060"}],"prev":{"headline":"POST File - Moderately critical - Cross Site Request Forgery - SA-CONTRIB-2024-059","id":"CVE-2024-13293"},"products":["POST File"],"published":"2025-01-09","related":[{"cvss_score":3.1,"headline":"POST File - Moderately critical - Cross Site Request Forgery - SA-CONTRIB-2024-059","id":"CVE-2024-13293","kev_date_added":null,"published":"2025-01-09"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"MIT","name":"Drupal","prefix":"DRUPAL"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-01-10","vendors":["Drupal"]},"summary":"Attackers can execute arbitrary PHP code and scripts via XSS in the Drupal POST File module, compromising site integrity.","url":"https://insights.sbomify.com/CVE-2024-13294/"}