{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2024-13296 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2024-13296 is a medium-severity unsafe deserialization vulnerability in Drupal Mailjet, published on 9 Jan 2025. An attacker needs administrator access to exploit it, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-13296 and fix it if it is affected.\n\nWhat it is: CVE-2024-13296 is a medium-severity unsafe deserialization vulnerability in Drupal Mailjet, published on 9 Jan 2025. An attacker needs administrator access to exploit it, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2024-13296 in the wild and no public exploit code.\n\nAffected product: Drupal Mailjet. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-13296/ (Markdown: https://insights.sbomify.com/CVE-2024-13296/index.md)","id":"CVE-2024-13296","markdown":"https://insights.sbomify.com/CVE-2024-13296/index.md","name":"CVE-2024-13296","record":{"aliases":["DRUPAL-CONTRIB-2024-062","GHSA-g6xh-8j45-qj24"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Drupal Mailjet module","requires_auth":"high_privilege","summary":"An attacker can execute arbitrary PHP code via unsafe deserialization in the Drupal Mailjet module, requiring an upgrade to secure the site.","user_interaction":"not_required","vuln_class":"deserialization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"drupal","cpe":[{"product":"mailjet","vendor":"mailjet"}],"cvss":{"score":6.6,"severity":"medium","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-502","name":"Deserialization of Untrusted Data"}],"description":"Deserialization of Untrusted Data vulnerability in Drupal Mailjet allows Object Injection.This issue affects Mailjet: from 0.0.0 before 4.0.1.","ecosystems":["Packagist:https://packages.drupal.org/8"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Mailjet - Moderately critical - Arbitrary PHP code execution - SA-CONTRIB-2024-062","id":"CVE-2024-13296","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"deserialization","year":"2024"},"n_packages":1,"n_references":1,"next":{"headline":"Eloqua - Moderately critical - Arbitrary PHP code execution - SA-CONTRIB-2024-063","id":"CVE-2024-13297"},"packages":[{"ecosystem":"Packagist:https://packages.drupal.org/8","fixed":["4.0.1"],"introduced":["0"],"last_affected":[],"package":"drupal/mailjet","purl":"pkg:composer/drupal/mailjet?repository_url=https:%2F%2Fpackages.drupal.org%2F8","source":"DRUPAL-CONTRIB-2024-062"}],"prev":{"headline":"Node export - Moderately critical - Arbitrary PHP code execution - SA-CONTRIB-2024-061","id":"CVE-2024-13295"},"products":["Mailjet"],"published":"2025-01-09","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"MIT","name":"Drupal","prefix":"DRUPAL"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-01-10","vendors":["Drupal"]},"summary":"An attacker can execute arbitrary PHP code via unsafe deserialization in the Drupal Mailjet module, requiring an upgrade to secure the site.","url":"https://insights.sbomify.com/CVE-2024-13296/"}