CVE-2024-13359 Product Input Fields for WooCommerce <= 1.12.0 - Unauthenticated Limited File Upload
Unauthenticated attackers can upload arbitrary files via double extensions, potentially leading to remote code execution on WordPress sites using this plugin.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- None listed
What is CVE-2024-13359?
CVE-2024-13359 is a high-severity vulnerability in tychesoftwares Product Input Fields for WooCommerce, published on 8 Mar 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
The Product Input Fields for WooCommerce plugin for WordPress is vulnerable to arbitrary file uploads due to insufficient file type validation in the add_product_input_fields_to_order_item_meta() function in all versions up to, and including, 1.12.0. This may make it possible for unauthenticated attackers to upload arbitrary files on the affected site's server which may make remote code execution possible. Please note that by default the plugin is only vulnerable to a double extension file upload attack, unless an administrators leaves the accepted file extensions field blank which can make .php file uploads possible. Please note 1.12.2 was mistakenly marked as patched while 1.12.1 was marked as vulnerable for a short period of time, this is not the case and 1.12.1 is fully patched.
Weakness: CWE-434
Which versions are affected by CVE-2024-13359?
It affects 1 product.
Products include Tychesoftwares Product Input Fields for Woocommerce.
How do I fix CVE-2024-13359?
No fix has been published for CVE-2024-13359 yet. Limit exposure of the affected software until one is available.
Is CVE-2024-13359 being exploited?
There is no known exploitation of CVE-2024-13359 in the wild and no public exploit code.
Other vulnerabilities in tychesoftwares Product Input Fields for WooCommerce
Sources
Also known as GHSA-fxpm-w54f-x564.