{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2024-13359 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2024-13359 yet. Limit exposure of the affected software until one is available.","what":"CVE-2024-13359 is a high-severity vulnerability in tychesoftwares Product Input Fields for WooCommerce, published on 8 Mar 2025. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-13359 and fix it if it is affected.\n\nWhat it is: CVE-2024-13359 is a high-severity vulnerability in tychesoftwares Product Input Fields for WooCommerce, published on 8 Mar 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2024-13359 in the wild and no public exploit code.\n\nAffected product: tychesoftwares Product Input Fields for WooCommerce. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-13359/ (Markdown: https://insights.sbomify.com/CVE-2024-13359/index.md)","id":"CVE-2024-13359","markdown":"https://insights.sbomify.com/CVE-2024-13359/index.md","name":"CVE-2024-13359","record":{"aliases":["GHSA-fxpm-w54f-x564"],"analysis":{"component_type":"cms_plugin","fix_type":"patch","impacts":["code_execution"],"network_reachable":"yes","non_default_config":true,"product_category":"WordPress plugin","requires_auth":"none","summary":"Unauthenticated attackers can upload arbitrary files via double extensions, potentially leading to remote code execution on WordPress sites using this plugin.","user_interaction":"not_required","vuln_class":"file_upload"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"Wordfence","cpe":[{"product":"product_input_fields_for_woocommerce","vendor":"tychesoftwares"}],"cvss":{"score":8.1,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-434","name":"Unrestricted Upload of File with Dangerous Type"}],"description":"The Product Input Fields for WooCommerce plugin for WordPress is vulnerable to arbitrary file uploads due to insufficient file type validation in the add_product_input_fields_to_order_item_meta() function in all versions up to, and including, 1.12.0. This may make it possible for unauthenticated attackers to upload arbitrary files on the affected site's server which may make remote code execution possible. Please note that by default the plugin is only vulnerable to a double extension file upload attack, unless an administrators leaves the accepted file extensions field blank which can make .php file uploads possible. Please note 1.12.2 was mistakenly marked as patched while 1.12.1 was marked as vulnerable for a short period of time, this is not the case and 1.12.1 is fully patched.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":null,"headline":"Product Input Fields for WooCommerce \u003c= 1.12.0 - Unauthenticated Limited File Upload","id":"CVE-2024-13359","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"file_upload","year":"2024"},"n_packages":0,"n_references":4,"next":{"headline":"AI Power: Complete AI Pack \u003c= 1.8.96 - Authenticated (Subscriber+) Server-Side Request Forgery","id":"CVE-2024-13360"},"packages":[],"prev":{"headline":"Missing authorization in BuddyPress WooCommerce My Account Integration. Create WooCommerce Member Pages","id":"CVE-2024-13358"},"products":["Product Input Fields for WooCommerce"],"published":"2025-03-08","related":[{"cvss_score":7.5,"headline":"Product Input Fields for WooCommerce \u003c= 1.2.6 - Missing Authorization","id":"CVE-2020-36696","kev_date_added":null,"published":"2023-06-07"},{"cvss_score":6.5,"headline":"Product Input Fields for WooCommerce \u003c= 1.9 - Authenticated (Contributor+) Arbitrary File Read","id":"CVE-2024-10857","kev_date_added":null,"published":"2024-11-26"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-04-08","vendors":["tychesoftwares"]},"summary":"Unauthenticated attackers can upload arbitrary files via double extensions, potentially leading to remote code execution on WordPress sites using this plugin.","url":"https://insights.sbomify.com/CVE-2024-13359/"}