# CVE-2024-13359: Product Input Fields for WooCommerce <= 1.12.0 - Unauthenticated Limited File Upload

> Unauthenticated attackers can upload arbitrary files via double extensions, potentially leading to remote code execution on WordPress sites using this plugin.

- **Severity:** High 8.1 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 8 Mar 2025
- **Updated:** 8 Apr 2026
- **Also known as:** GHSA-fxpm-w54f-x564

## What is CVE-2024-13359?

CVE-2024-13359 is a high-severity vulnerability in tychesoftwares Product Input Fields for WooCommerce, published on 8 Mar 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The Product Input Fields for WooCommerce plugin for WordPress is vulnerable to arbitrary file uploads due to insufficient file type validation in the add_product_input_fields_to_order_item_meta() function in all versions up to, and including, 1.12.0. This may make it possible for unauthenticated attackers to upload arbitrary files on the affected site's server which may make remote code execution possible. Please note that by default the plugin is only vulnerable to a double extension file upload attack, unless an administrators leaves the accepted file extensions field blank which can make .php file uploads possible. Please note 1.12.2 was mistakenly marked as patched while 1.12.1 was marked as vulnerable for a short period of time, this is not the case and 1.12.1 is fully patched.

Weakness: CWE-434 (Unrestricted Upload of File with Dangerous Type)

## Which versions are affected by CVE-2024-13359?

It affects 1 product.


Products: Tychesoftwares Product Input Fields for Woocommerce.

## How do I fix CVE-2024-13359?

No fix has been published for CVE-2024-13359 yet. Limit exposure of the affected software until one is available.

## Is CVE-2024-13359 being exploited?

There is no known exploitation of CVE-2024-13359 in the wild and no public exploit code.

## Other vulnerabilities in tychesoftwares Product Input Fields for WooCommerce

- [CVE-2020-36696](https://insights.sbomify.com/CVE-2020-36696/): Product Input Fields for WooCommerce <= 1.2.6 - Missing Authorization (high 7.5)
- [CVE-2024-10857](https://insights.sbomify.com/CVE-2024-10857/): Product Input Fields for WooCommerce <= 1.9 - Authenticated (Contributor+) Arbitrary File Read (medium 6.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-13359 and fix it if it is affected.

What it is: CVE-2024-13359 is a high-severity vulnerability in tychesoftwares Product Input Fields for WooCommerce, published on 8 Mar 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-13359 in the wild and no public exploit code.

Affected product: tychesoftwares Product Input Fields for WooCommerce. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-13359/ (Markdown: https://insights.sbomify.com/CVE-2024-13359/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-13359
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-13359
- OSV: https://osv.dev/vulnerability/CVE-2024-13359

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-13359/
Summaries are generated and may contain mistakes; the official description above is the record.
