{"answers":{"affected":"","exploited":"There is no known exploitation of CVE-2024-13427 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2024-13427 yet. Limit exposure of the affected software until one is available.","what":"CVE-2024-13427 is a medium-severity cross-site scripting vulnerability in softaculous Page Builder: Pagelayer – Drag and Drop website builder, published on 24 May 2025. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-13427 and fix it if it is affected.\n\nWhat it is: CVE-2024-13427 is a medium-severity cross-site scripting vulnerability in softaculous Page Builder: Pagelayer – Drag and Drop website builder, published on 24 May 2025. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2024-13427 in the wild and no public exploit code.\n\nAffected product: softaculous Page Builder: Pagelayer – Drag and Drop website builder. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-13427/ (Markdown: https://insights.sbomify.com/CVE-2024-13427/index.md)","id":"CVE-2024-13427","markdown":"https://insights.sbomify.com/CVE-2024-13427/index.md","name":"CVE-2024-13427","record":{"aliases":["GHSA-2cr5-mf95-c6r3"],"analysis":{"component_type":"cms_plugin","fix_type":"patch","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"WordPress plugin","requires_auth":"low_privilege","summary":"Authenticated contributors can inject arbitrary scripts via the Button widget, leading to stored XSS execution for other users.","user_interaction":"not_required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"Wordfence","cpe":[],"cvss":{"score":6.4,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"The Page Builder: Pagelayer – Drag and Drop website builder plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's Button widget in all versions up to, and including, 2.0.0 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. NOTE: This vulnerability was partially fixed in version 1.9.9 and completely fixed in version 2.0.1.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":null,"headline":"Cross-site scripting in Page Builder: Pagelayer – Drag and Drop website builder","id":"CVE-2024-13427","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"xss","year":"2024"},"n_packages":0,"n_references":2,"next":{"headline":"WP Job Portal \u003c= 2.2.6 - Insecure Direct Object Reference to Unauthenticated Company Logo Deletion","id":"CVE-2024-13428"},"packages":[],"prev":{"headline":"WP-Polls \u003c= 2.77.2 - Unauthenticated SQL Injection to Stored Cross-Site Scripting","id":"CVE-2024-13426"},"products":["Page Builder: Pagelayer – Drag and Drop website builder"],"published":"2025-05-24","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-04-08","vendors":["softaculous"]},"summary":"Authenticated contributors can inject arbitrary scripts via the Button widget, leading to stored XSS execution for other users.","url":"https://insights.sbomify.com/CVE-2024-13427/"}