CVE-2024-1347 Authentication Bypass by Spoofing in GitLab

Medium 4.3 Published Updated

Attackers can bypass domain restrictions using crafted email addresses, requiring GitLab administrators to upgrade to secure versions.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2024-1347?

CVE-2024-1347 is a medium-severity authentication bypass vulnerability in Gitlab Gitlab, published on 25 Apr 2024. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

An issue has been discovered in GitLab CE/EE affecting all versions before 16.9.6, all versions starting from 16.10 before 16.10.4, all versions starting from 16.11 before 16.11.1. Under certain conditions, an attacker through a crafted email address may be able to bypass domain based restrictions on an instance or a group.

Weakness: CWE-290

Which versions are affected by CVE-2024-1347?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiAll versions16.9.6, 16.10.4, 16.11.1

Products include Gitlab Gitlab.

How do I fix CVE-2024-1347?

Upgrade gitlab to a fixed version for your release line: 16.9.6, 16.10.4 or 16.11.1.

Upgrade, and rotate credentials and sessions that may have been exposed. More about Authentication bypass.

Is CVE-2024-1347 being exploited?

There is no known exploitation of CVE-2024-1347 in the wild and no public exploit code.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2024-1347, GHSA-2x3p-pww2-fg9r, UBUNTU-CVE-2024-1347.

Is CVE-2024-1347 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free