# CVE-2024-13496: GamiPress <= 7.3.1 - Unauthenticated SQL Injection via orderby Parameter

> Unauthenticated attackers can exploit SQL injection in the orderby parameter to extract sensitive database information from the GamiPress WordPress plugin.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 22 Jan 2025
- **Updated:** 8 Apr 2026
- **Also known as:** GHSA-wx72-gcvw-cjv8

## What is CVE-2024-13496?

CVE-2024-13496 is a high-severity SQL injection vulnerability in rubengc GamiPress – Gamification plugin to reward points, achievements, badges & ranks in WordPress, published on 22 Jan 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The GamiPress – Gamification plugin to reward points, achievements, badges & ranks in WordPress plugin for WordPress is vulnerable to time-based SQL Injection via the ‘orderby’ parameter in all versions up to, and including, 7.3.1 due to insufficient escaping on the user supplied parameter and lack of sufficient preparation on the existing SQL query.  This makes it possible for unauthenticated attackers to append additional SQL queries into already existing queries that can be used to extract sensitive information from the database. NOTE: This vulnerability was previously published as being fixed in version 7.2.2 which was incorrect. The correct fixed version is 7.3.2.

Weakness: CWE-89 (Improper Neutralization of Special Elements used in an SQL Command)

## Which versions are affected by CVE-2024-13496?

It affects 1 product.


Products: Gamipress Gamipress.

## How do I fix CVE-2024-13496?

No fix has been published for CVE-2024-13496 yet. Limit exposure of the affected software until one is available.

## Is CVE-2024-13496 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-13496 exists.

Public exploit code:

- GamiPress <= 2.8.9 - SQL Injection (nuclei): http/cves/2024/CVE-2024-13496.yaml

## Other vulnerabilities in rubengc GamiPress – Gamification plugin to reward points, achievements, badges & ranks in WordPress

- [CVE-2024-1799](https://insights.sbomify.com/CVE-2024-1799/): SQL injection in GamiPress – Gamification plugin to reward points, achievements, badges & ranks in WordPress (high 8.8)
- [CVE-2023-24000](https://insights.sbomify.com/CVE-2023-24000/): WordPress GamiPress Plugin <= 2.5.7 is vulnerable to SQL Injection (high 8.2)
- [CVE-2024-2505](https://insights.sbomify.com/CVE-2024-2505/): GamiPress < 6.8.9 - Broken Access Control (high 8.1)
- [CVE-2024-13495](https://insights.sbomify.com/CVE-2024-13495/): GamiPress <= 7.2.1 - Unauthenticated Arbitrary Shortcode Execution via gamipress_ajax_get_logs Function (high 7.3)
- [CVE-2024-13499](https://insights.sbomify.com/CVE-2024-13499/): GamiPress <= 7.2.1 - Unauthenticated Arbitrary Shortcode Execution via gamipress_do_shortcode() Function (high 7.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-13496 and fix it if it is affected.

What it is: CVE-2024-13496 is a high-severity SQL injection vulnerability in rubengc GamiPress – Gamification plugin to reward points, achievements, badges & ranks in WordPress, published on 22 Jan 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-13496 exists.

Affected product: rubengc GamiPress – Gamification plugin to reward points, achievements, badges & ranks in WordPress. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-13496/ (Markdown: https://insights.sbomify.com/CVE-2024-13496/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-13496
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-13496
- OSV: https://osv.dev/vulnerability/CVE-2024-13496

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-13496/
Summaries are generated and may contain mistakes; the official description above is the record.
