{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2024-13509 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2024-13509 yet. Limit exposure of the affected software until one is available.","what":"CVE-2024-13509 is a high-severity cross-site scripting vulnerability in WS Form LITE – Drag \u0026 Drop Contact Form Builder, published on 28 Jan 2025. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-13509 and fix it if it is affected.\n\nWhat it is: CVE-2024-13509 is a high-severity cross-site scripting vulnerability in WS Form LITE – Drag \u0026 Drop Contact Form Builder, published on 28 Jan 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2024-13509 in the wild and no public exploit code.\n\nAffected product: WS Form LITE – Drag \u0026 Drop Contact Form Builder. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-13509/ (Markdown: https://insights.sbomify.com/CVE-2024-13509/index.md)","id":"CVE-2024-13509","markdown":"https://insights.sbomify.com/CVE-2024-13509/index.md","name":"CVE-2024-13509","record":{"aliases":["GHSA-qqrp-rh67-96r2"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"WordPress form plugin","requires_auth":"none","summary":"Unauthenticated attackers can inject arbitrary web scripts via the url parameter, leading to stored XSS when users view affected pages.","user_interaction":"not_required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"Wordfence","cpe":[{"product":"ws_form","vendor":"westguardsolutions"}],"cvss":{"score":7.2,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"The WS Form LITE and PRO plugins for WordPress are vulnerable to Stored Cross-Site Scripting via the url parameter in all versions up to, and including, 1.10.13 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. NOTE: This vulnerability is partially fixed in 1.10.13 and completely fixed in 1.10.14.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":null,"headline":"WS Form LITE and PRO \u003c= 1.10.13 - Unauthenticated Stored Cross-Site Scripting","id":"CVE-2024-13509","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"xss","year":"2024"},"n_packages":0,"n_references":4,"next":{"headline":"ShopSite \u003c= 1.5.10 - Cross-Site Request Forgery to Stored Cross-Site Scripting","id":"CVE-2024-13510"},"packages":[],"prev":{"headline":"Booking Package \u003c= 1.6.72 - Reflected Cross-Site Scripting via Locale Parameter","id":"CVE-2024-13508"},"products":["WS Form LITE – Drag \u0026 Drop Contact Form Builder","WS Form Pro"],"published":"2025-01-28","related":[{"cvss_score":7.6,"headline":"WordPress WS Form LITE Plugin \u003c= 1.9.170 is vulnerable to SQL Injection","id":"CVE-2023-52135","kev_date_added":null,"published":"2023-12-29"},{"cvss_score":6.1,"headline":"WS Form LITE – Drag \u0026 Drop Contact Form Builder for WordPress \u003c= 1.9.244 - Reflected Cross-Site Scripting via URL","id":"CVE-2024-10647","kev_date_added":null,"published":"2024-11-06"},{"cvss_score":6.1,"headline":"WS Form \u003c 1.8.176 - Unauthenticated Stored Cross-Site Scripting","id":"CVE-2022-23988","kev_date_added":null,"published":"2022-02-28"},{"cvss_score":4.8,"headline":"WS Form \u003c 1.8.176 - Admin+ Stored Cross-Site Scripting","id":"CVE-2022-23987","kev_date_added":null,"published":"2022-02-28"},{"cvss_score":4.7,"headline":"WS Form LITE \u003c= 1.9.217 - Unauthenticated CSV Injection","id":"CVE-2023-5424","kev_date_added":null,"published":"2024-06-07"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-04-08","vendors":["WS Form","westguard"]},"summary":"Unauthenticated attackers can inject arbitrary web scripts via the url parameter, leading to stored XSS when users view affected pages.","url":"https://insights.sbomify.com/CVE-2024-13509/"}