# CVE-2024-1351: MongoDB Server may allow successful untrusted connection

> Attackers can bypass TLS certificate validation in MongoDB Server when specific TLS configurations are missing, allowing untrusted connections.

- **Severity:** High 8.8 (`CVSS:3.1/AV:A/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 Mar 2024
- **Updated:** 13 Feb 2025
- **Also known as:** BIT-mongodb-2024-1351, GHSA-825c-4w2m-h7fv, UBUNTU-CVE-2024-1351

## What is CVE-2024-1351?

CVE-2024-1351 is a high-severity vulnerability in Mongodb Mongodb, published on 7 Mar 2024. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

Under certain configurations of --tlsCAFile and tls.CAFile, MongoDB Server may skip peer certificate validation which may result in untrusted connections to succeed. This may effectively reduce the security guarantees provided by TLS and open connections  that should have been closed due to failing certificate validation. This issue affects MongoDB Server v7.0 versions prior to and including 7.0.5, MongoDB Server v6.0 versions prior to and including 6.0.13, MongoDB Server v5.0 versions prior to and including 5.0.24 and MongoDB Server v4.4 versions prior to and including 4.4.28.

Required Configuration : A server process will allow incoming connections to skip peer certificate validation if the server process was started with TLS enabled (net.tls.mode set to allowTLS, preferTLS, or requireTLS) and without a net.tls.CAFile configured.

Weakness: CWE-295 (Improper Certificate Validation)

## Which versions are affected by CVE-2024-1351?

1 open source package ship an affected version, including mongodb. It affects 3 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mongodb` | Bitnami | From 4.4.0 | 5.0.26, 6.0.14, 7.0.7 |

Products: Mongodb Mongodb, Netapp Astra Control Center, Netapp Ontap Tools.

## How do I fix CVE-2024-1351?

Upgrade mongodb to a fixed version for your release line: 5.0.26, 6.0.14 or 7.0.7.

## Is CVE-2024-1351 being exploited?

There is no known exploitation of CVE-2024-1351 in the wild and no public exploit code.

## Other vulnerabilities in Mongodb Mongodb

- [CVE-2025-14847](https://insights.sbomify.com/CVE-2025-14847/): MongoDB and MongoDB Server Improper Handling of Length Parameter Inconsistency (high 8.7, exploited in the wild)
- [CVE-2026-82067](https://insights.sbomify.com/CVE-2026-82067/): Auth bypass in MongoDB Server (critical 9.2)
- [CVE-2026-13072](https://insights.sbomify.com/CVE-2026-13072/): MongoDB Improper Input Validation in Compute Mode External Data Processing Leading to Memory Corruption (critical 9.2)
- [CVE-2017-15535](https://insights.sbomify.com/CVE-2017-15535/): Denial of service in n/a (critical 9.1)
- [CVE-2026-18691](https://insights.sbomify.com/CVE-2026-18691/): Improper Authentication in MongoDB Intra-Cluster Connections Allows Credential Exposure (critical 9.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-1351 and fix it if it is affected.

What it is: CVE-2024-1351 is a high-severity vulnerability in Mongodb Mongodb, published on 7 Mar 2024. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-1351 in the wild and no public exploit code.

Affected packages and fixed versions:
- mongodb (Bitnami): affected from 4.4.0; fixed in 5.0.26, 6.0.14, 7.0.7

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-1351/ (Markdown: https://insights.sbomify.com/CVE-2024-1351/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-1351
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-1351
- OSV: https://osv.dev/vulnerability/CVE-2024-1351

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-1351/
Summaries are generated and may contain mistakes; the official description above is the record.
