# CVE-2024-13554: Missing authorization in The Ultimate WordPress Toolkit – WP Extended

> Unauthenticated attackers can manipulate post order due to missing capability checks in the WP Extended plugin.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 12 Feb 2025
- **Updated:** 8 Apr 2026
- **Also known as:** GHSA-6fmm-5c95-w3xg

## What is CVE-2024-13554?

CVE-2024-13554 is a medium-severity missing authorization vulnerability in wpextended The Ultimate WordPress Toolkit – WP Extended, published on 12 Feb 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The The Ultimate WordPress Toolkit – WP Extended plugin for WordPress is vulnerable to unauthorized modification of data due to a missing capability check on the reorder_route() function in all versions up to, and including, 3.0.13. This makes it possible for unauthenticated attackers to reorder posts.

Weakness: CWE-862 (Missing Authorization)

## Which versions are affected by CVE-2024-13554?

It affects 1 product.


Products: Wpextended Wp Extended.

## How do I fix CVE-2024-13554?

No fix has been published for CVE-2024-13554 yet. Limit exposure of the affected software until one is available.

## Is CVE-2024-13554 being exploited?

There is no known exploitation of CVE-2024-13554 in the wild and no public exploit code.

## Other vulnerabilities in wpextended The Ultimate WordPress Toolkit – WP Extended

- [CVE-2024-8102](https://insights.sbomify.com/CVE-2024-8102/): The Ultimate WordPress Toolkit – WP Extended <= 3.0.8 - Authenticated (Subscriber+) Arbitrary Options Update (high 8.8)
- [CVE-2024-8104](https://insights.sbomify.com/CVE-2024-8104/): Path traversal in The Ultimate WordPress Toolkit – WP Extended (high 8.8)
- [CVE-2024-11916](https://insights.sbomify.com/CVE-2024-11916/): Missing authorization in The Ultimate WordPress Toolkit – WP Extended (high 7.4)
- [CVE-2024-37259](https://insights.sbomify.com/CVE-2024-37259/): WordPress WP Extended plugin <= 2.4.7 - Cross Site Scripting (XSS) vulnerability (high 7.1)
- [CVE-2024-8106](https://insights.sbomify.com/CVE-2024-8106/): The Ultimate WordPress Toolkit – WP Extended <= 3.0.8 - Authenticated (Subscriber+) Sensitive Information Exposure (medium 6.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-13554 and fix it if it is affected.

What it is: CVE-2024-13554 is a medium-severity missing authorization vulnerability in wpextended The Ultimate WordPress Toolkit – WP Extended, published on 12 Feb 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-13554 in the wild and no public exploit code.

Affected product: wpextended The Ultimate WordPress Toolkit – WP Extended. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-13554/ (Markdown: https://insights.sbomify.com/CVE-2024-13554/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-13554
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-13554
- OSV: https://osv.dev/vulnerability/CVE-2024-13554

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-13554/
Summaries are generated and may contain mistakes; the official description above is the record.
