CVE-2024-13699 Qi Addons For Elementor <= 1.8.7 - Authenticated (Contributor+) Stored Cross-Site Scripting
Authenticated attackers with Contributor access can inject arbitrary scripts via the cursor parameter, leading to stored XSS execution on victim pages.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- None listed
What is CVE-2024-13699?
CVE-2024-13699 is a medium-severity cross-site scripting vulnerability in qodeinteractive Qi Addons For Elementor, published on 4 Feb 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
The Qi Addons For Elementor plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the ‘cursor’ parameter in all versions up to, and including, 1.8.7 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. The vulnerability was partially patched in versions 1.8.5, 1.8.6, and 1.8.7.
Weakness: CWE-79
Which versions are affected by CVE-2024-13699?
It affects 1 product.
Products include Qodeinteractive Qi Addons for Elementor.
How do I fix CVE-2024-13699?
No fix has been published for CVE-2024-13699 yet. Limit exposure of the affected software until one is available.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2024-13699 being exploited?
There is no known exploitation of CVE-2024-13699 in the wild and no public exploit code.
Other vulnerabilities in qodeinteractive Qi Addons For Elementor
- CVE-2024-4887 Qi Addons For Elementor <= 1.7.2 - Authenticated (Contributor+) Local File Inclusion
- CVE-2023-47680 WordPress Qi Addons For Elementor Plugin <= 1.6.3 is vulnerable to Cross Site Scripting (XSS)
- CVE-2025-6252 Qi Addons For Elementor <= 1.9.1 - Authenticated (Contributor+) Stored Cross-Site Scripting
- CVE-2024-4364 Qi Addons For Elementor <= 1.7.2 - Authenticated (Contributor+) Stored Cross-Site Scripting via Button Widget
- CVE-2023-47679 WordPress Qi Addons For Elementor plugin <= 1.6.3 - Local File Inclusion vulnerability
Sources
Also known as GHSA-x4gm-qv5j-r6rh.