{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2024-1374 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2024-1374 yet. Limit exposure of the affected software until one is available.","what":"CVE-2024-1374 is a critical command injection vulnerability in Github Enterprise Server, published on 13 Feb 2024. An attacker needs administrator access to exploit it, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-1374 and fix it if it is affected.\n\nWhat it is: CVE-2024-1374 is a critical command injection vulnerability in Github Enterprise Server, published on 13 Feb 2024. An attacker needs administrator access to exploit it, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2024-1374 in the wild and no public exploit code.\n\nAffected product: Github Enterprise Server. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-1374/ (Markdown: https://insights.sbomify.com/CVE-2024-1374/index.md)","id":"CVE-2024-1374","markdown":"https://insights.sbomify.com/CVE-2024-1374/index.md","name":"CVE-2024-1374","record":{"aliases":["GHSA-9779-f4qr-x2w9"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["privilege_escalation","code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"GitHub Enterprise Server","requires_auth":"high_privilege","summary":"An editor in the Management Console can inject commands to gain admin SSH access, requiring an upgrade to secure the appliance.","user_interaction":"not_required","vuln_class":"command_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_P","cpe":[{"product":"enterprise_server","vendor":"github"}],"cvss":{"score":9.1,"severity":"critical","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-77","name":"Improper Neutralization of Special Elements used in a Command"},{"id":"CWE-20","name":"Improper Input Validation"}],"description":"A command injection vulnerability was identified in GitHub Enterprise Server that allowed an attacker with an editor role in the Management Console to gain admin SSH access to the appliance via nomad templates when configuring audit log forwarding. Exploitation of this vulnerability required access to the GitHub Enterprise Server instance and access to the Management Console with the editor role. This vulnerability affected all versions of GitHub Enterprise Server prior to 3.12 and was fixed in versions 3.11.5, 3.10.7, 3.9.10, and 3.8.15. This vulnerability was reported via the  GitHub Bug Bounty program https://bounty.github.com .","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":null,"headline":"Command injection in Enterprise Server","id":"CVE-2024-1374","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":"github:enterprise_server","products":["github:enterprise_server"],"type":"command_injection","year":"2024"},"n_packages":0,"n_references":4,"next":{"headline":"Event post \u003c= 5.9.10 - Cross-Site Request Forgery","id":"CVE-2024-1375"},"packages":[],"prev":{"headline":"Command injection in Enterprise Server","id":"CVE-2024-1372"},"products":["Enterprise Server"],"published":"2024-02-13","related":[{"cvss_score":10,"headline":"Auth bypass in Enterprise Server","id":"CVE-2024-4985","kev_date_added":null,"published":"2024-05-20"},{"cvss_score":9.8,"headline":"Missing authorization in GitHub Enterprise Server","id":"CVE-2022-23739","kev_date_added":null,"published":"2023-01-17"},{"cvss_score":9.8,"headline":"Improper Limitation of a Pathname to a Restricted Directory in GitHub Enterprise Server leading to RCE","id":"CVE-2022-46255","kev_date_added":null,"published":"2022-12-14"},{"cvss_score":9.8,"headline":"Improper access control in GitHub Enterprise Server allows self-hosted runners to execute outside their control group","id":"CVE-2021-22869","kev_date_added":null,"published":"2021-09-24"},{"cvss_score":9.5,"headline":"Auth bypass in Enterprise Server","id":"CVE-2024-9487","kev_date_added":null,"published":"2024-10-10"},{"cvss_score":9.5,"headline":"Auth bypass in GitHub Enterprise Server","id":"CVE-2024-6800","kev_date_added":null,"published":"2024-08-20"},{"cvss_score":9.3,"headline":"GitHub Enterprise Server notebook viewer vulnerable to Server-side request forgery","id":"CVE-2026-77987","kev_date_added":null,"published":"2026-09-22"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-05-09","vendors":["GitHub"]},"summary":"An editor in the Management Console can inject commands to gain admin SSH access, requiring an upgrade to secure the appliance.","url":"https://insights.sbomify.com/CVE-2024-1374/"}