{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2024-13816 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2024-13816 yet. Limit exposure of the affected software until one is available.","what":"CVE-2024-13816 is a medium-severity missing authorization vulnerability in CodeRevolution Aiomatic - Automatic AI Content Writer \u0026 Editor, GPT-3 \u0026 GPT-4, ChatGPT ChatBot \u0026 AI Toolkit, published on 8 Mar 2025. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-13816 and fix it if it is affected.\n\nWhat it is: CVE-2024-13816 is a medium-severity missing authorization vulnerability in CodeRevolution Aiomatic - Automatic AI Content Writer \u0026 Editor, GPT-3 \u0026 GPT-4, ChatGPT ChatBot \u0026 AI Toolkit, published on 8 Mar 2025. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2024-13816 in the wild and no public exploit code.\n\nAffected product: CodeRevolution Aiomatic - Automatic AI Content Writer \u0026 Editor, GPT-3 \u0026 GPT-4, ChatGPT ChatBot \u0026 AI Toolkit. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-13816/ (Markdown: https://insights.sbomify.com/CVE-2024-13816/index.md)","id":"CVE-2024-13816","markdown":"https://insights.sbomify.com/CVE-2024-13816/index.md","name":"CVE-2024-13816","record":{"aliases":["GHSA-fxrj-98xj-j69p"],"analysis":{"component_type":"cms_plugin","fix_type":"patch","impacts":["data_modify","data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"WordPress plugin","requires_auth":"low_privilege","summary":"Authenticated subscribers can perform unauthorized administrative actions like deleting posts and templates due to missing capability checks.","user_interaction":"not_required","vuln_class":"missing_authorization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"Wordfence","cpe":[{"product":"aiomatic","vendor":"coderevolution"}],"cvss":{"score":5.4,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-862","name":"Missing Authorization"}],"description":"The Aiomatic - Automatic AI Content Writer \u0026 Editor, GPT-3 \u0026 GPT-4, ChatGPT ChatBot \u0026 AI Toolkit plugin for WordPress is vulnerable to unauthorized access, modification, and loss of data due to a missing capability checks on multiple functions in all versions up to, and including, 2.3.6. This makes it possible for authenticated attackers, with Subscriber-level access and above, to update and delete posts, list and delete batches, list assistant uploaded files, delete personas, delete forms, delete templates, and clear logs. The vulnerability was partially patched in version 2.3.5.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":null,"headline":"Missing authorization in Aiomatic - Automatic AI Content Writer \u0026 Editor, GPT-3 \u0026 GPT-4, ChatGPT ChatBot \u0026 AI Toolkit","id":"CVE-2024-13816","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"missing_authorization","year":"2024"},"n_packages":0,"n_references":2,"next":{"headline":"** REJECT ** DO NOT USE THIS CANDIDATE NUMBER.","id":"CVE-2024-13817"},"packages":[],"prev":{"headline":"Listingo - Business Listing and Directory WordPress Theme \u003c= 3.2.7 - Unauthenticated Arbitrary Shortcode Execution","id":"CVE-2024-13815"},"products":["Aiomatic - Automatic AI Content Writer \u0026 Editor, GPT-3 \u0026 GPT-4, ChatGPT ChatBot \u0026 AI Toolkit"],"published":"2025-03-08","related":[{"cvss_score":8.8,"headline":"File upload in Aiomatic - Automatic AI Content Writer \u0026 Editor, GPT-3 \u0026 GPT-4, ChatGPT ChatBot \u0026 AI Toolkit","id":"CVE-2024-13882","kev_date_added":null,"published":"2025-03-08"},{"cvss_score":7.5,"headline":"Aiomatic - AI Content Writer, Editor, ChatBot \u0026 AI Toolkit \u003c= 2.5.0 - Authenticated (Subscriber+) Arbitrary File Upload","id":"CVE-2025-6206","kev_date_added":null,"published":"2025-06-24"},{"cvss_score":5.8,"headline":"AIomatic - Automatic AI Content Writer \u003c= 2.0.5 - Unauthenticated Arbitrary Email Sending","id":"CVE-2024-5969","kev_date_added":null,"published":"2024-07-27"},{"cvss_score":4.3,"headline":"WordPress Aiomatic plugin \u003c= 1.9.3 - Broken Access Control vulnerability","id":"CVE-2024-34435","kev_date_added":null,"published":"2024-06-09"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-04-08","vendors":["CodeRevolution"]},"summary":"Authenticated subscribers can perform unauthorized administrative actions like deleting posts and templates due to missing capability checks.","url":"https://insights.sbomify.com/CVE-2024-13816/"}