# CVE-2024-13816: Missing authorization in Aiomatic - Automatic AI Content Writer & Editor, GPT-3 & GPT-4, ChatGPT ChatBot & AI Toolkit

> Authenticated subscribers can perform unauthorized administrative actions like deleting posts and templates due to missing capability checks.

- **Severity:** Medium 5.4 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 8 Mar 2025
- **Updated:** 8 Apr 2026
- **Also known as:** GHSA-fxrj-98xj-j69p

## What is CVE-2024-13816?

CVE-2024-13816 is a medium-severity missing authorization vulnerability in CodeRevolution Aiomatic - Automatic AI Content Writer & Editor, GPT-3 & GPT-4, ChatGPT ChatBot & AI Toolkit, published on 8 Mar 2025. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

The Aiomatic - Automatic AI Content Writer & Editor, GPT-3 & GPT-4, ChatGPT ChatBot & AI Toolkit plugin for WordPress is vulnerable to unauthorized access, modification, and loss of data due to a missing capability checks on multiple functions in all versions up to, and including, 2.3.6. This makes it possible for authenticated attackers, with Subscriber-level access and above, to update and delete posts, list and delete batches, list assistant uploaded files, delete personas, delete forms, delete templates, and clear logs. The vulnerability was partially patched in version 2.3.5.

Weakness: CWE-862 (Missing Authorization)

## Which versions are affected by CVE-2024-13816?

It affects 1 product.


Products: Coderevolution Aiomatic.

## How do I fix CVE-2024-13816?

No fix has been published for CVE-2024-13816 yet. Limit exposure of the affected software until one is available.

## Is CVE-2024-13816 being exploited?

There is no known exploitation of CVE-2024-13816 in the wild and no public exploit code.

## Other vulnerabilities in CodeRevolution Aiomatic - Automatic AI Content Writer & Editor, GPT-3 & GPT-4, ChatGPT ChatBot & AI Toolkit

- [CVE-2024-13882](https://insights.sbomify.com/CVE-2024-13882/): File upload in Aiomatic - Automatic AI Content Writer & Editor, GPT-3 & GPT-4, ChatGPT ChatBot & AI Toolkit (high 8.8)
- [CVE-2025-6206](https://insights.sbomify.com/CVE-2025-6206/): Aiomatic - AI Content Writer, Editor, ChatBot & AI Toolkit <= 2.5.0 - Authenticated (Subscriber+) Arbitrary File Upload (high 7.5)
- [CVE-2024-5969](https://insights.sbomify.com/CVE-2024-5969/): AIomatic - Automatic AI Content Writer <= 2.0.5 - Unauthenticated Arbitrary Email Sending (medium 5.8)
- [CVE-2024-34435](https://insights.sbomify.com/CVE-2024-34435/): WordPress Aiomatic plugin <= 1.9.3 - Broken Access Control vulnerability (medium 4.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-13816 and fix it if it is affected.

What it is: CVE-2024-13816 is a medium-severity missing authorization vulnerability in CodeRevolution Aiomatic - Automatic AI Content Writer & Editor, GPT-3 & GPT-4, ChatGPT ChatBot & AI Toolkit, published on 8 Mar 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-13816 in the wild and no public exploit code.

Affected product: CodeRevolution Aiomatic - Automatic AI Content Writer & Editor, GPT-3 & GPT-4, ChatGPT ChatBot & AI Toolkit. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-13816/ (Markdown: https://insights.sbomify.com/CVE-2024-13816/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-13816
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-13816
- OSV: https://osv.dev/vulnerability/CVE-2024-13816

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-13816/
Summaries are generated and may contain mistakes; the official description above is the record.
