{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2024-13860 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2024-13860 yet. Limit exposure of the affected software until one is available.","what":"CVE-2024-13860 is a medium-severity cross-site scripting vulnerability in BuddyBoss Platform, published on 2 May 2025. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-13860 and fix it if it is affected.\n\nWhat it is: CVE-2024-13860 is a medium-severity cross-site scripting vulnerability in BuddyBoss Platform, published on 2 May 2025. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2024-13860 in the wild and no public exploit code.\n\nAffected product: BuddyBoss Platform. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-13860/ (Markdown: https://insights.sbomify.com/CVE-2024-13860/index.md)","id":"CVE-2024-13860","markdown":"https://insights.sbomify.com/CVE-2024-13860/index.md","name":"CVE-2024-13860","record":{"aliases":["GHSA-3qjj-xgvq-44qh"],"analysis":{"component_type":"cms_plugin","fix_type":"patch","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"WordPress plugin","requires_auth":"low_privilege","summary":"Authenticated attackers can inject arbitrary scripts via the topic title parameter, leading to script execution in victim browsers.","user_interaction":"not_required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"Wordfence","cpe":[{"product":"buddyboss_platform","vendor":"buddyboss"}],"cvss":{"score":6.4,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"The Buddyboss Platform plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the ‘bbp_topic_title’ parameter in all versions up to, and including, 2.8.50 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Subscriber-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. The vulnerability was partially patched in version 2.8.41.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":false,"headline":"BuddyBoss Platform \u003c= 2.8.50 - Authenticated (Subscriber+) Stored Cross-Site Scripting via 'bbp_topic_title'","id":"CVE-2024-13860","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"xss","year":"2024"},"n_packages":0,"n_references":3,"next":{"headline":"Code injection in Taegis Endpoint Agent (Linux)","id":"CVE-2024-13861"},"packages":[],"prev":{"headline":"Cross-site scripting in BuddyBoss Platform","id":"CVE-2024-13859"},"products":["BuddyBoss Platform"],"published":"2025-05-02","related":[{"cvss_score":9.8,"headline":"BuddyBoss Platform Pro \u003c= 2.7.01 - Authentication Bypass via Apple OAuth provider","id":"CVE-2025-1909","kev_date_added":null,"published":"2025-05-05"},{"cvss_score":6.4,"headline":"Cross-site scripting in BuddyBoss Platform","id":"CVE-2024-13858","kev_date_added":null,"published":"2025-05-02"},{"cvss_score":6.4,"headline":"Cross-site scripting in BuddyBoss Platform","id":"CVE-2024-13859","kev_date_added":null,"published":"2025-05-02"},{"cvss_score":6.4,"headline":"BuddyBoss Platform \u003c= 2.7.70 - Authenticated (Subscriber+) Stored Cross-Site Scripting via 'link_title'","id":"CVE-2024-13402","kev_date_added":null,"published":"2025-02-27"},{"cvss_score":4.3,"headline":"BuddyBoss Platform \u003c 2.6.0 - Subscriber+ Comment on Private Post via IDOR","id":"CVE-2024-4886","kev_date_added":null,"published":"2024-06-05"},{"cvss_score":3.5,"headline":"BuddyBoss platform \u003c 2.7.60 - Private Comment Exposure via IDOR","id":"CVE-2024-12767","kev_date_added":null,"published":"2025-05-15"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-04-08","vendors":["Boss Media"]},"summary":"Authenticated attackers can inject arbitrary scripts via the topic title parameter, leading to script execution in victim browsers.","url":"https://insights.sbomify.com/CVE-2024-13860/"}