CVE-2024-13903 quickjs-ng QuickJS qjs quickjs.c JS_GetRuntime stack-based overflow

Medium 5.3 Published Updated

A stack-based buffer overflow in QuickJS allows remote attackers to execute arbitrary code or cause denial of service.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
None listed

What is CVE-2024-13903?

CVE-2024-13903 is a medium-severity memory corruption vulnerability in quickjs-ng QuickJS, published on 21 Mar 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

Official description

A vulnerability was found in quickjs-ng QuickJS up to 0.8.0. It has been declared as problematic. Affected by this vulnerability is the function JS_GetRuntime of the file quickjs.c of the component qjs. The manipulation leads to stack-based buffer overflow. The attack can be launched remotely. Upgrading to version 0.9.0 is able to address this issue. The patch is named 99c02eb45170775a9a679c32b45dd4000ea67aff. It is recommended to upgrade the affected component.

Weakness: CWE-121, CWE-787, CWE-119

Which versions are affected by CVE-2024-13903?

It affects 1 product.

Products include Quickjs-Ng Quickjs.

How do I fix CVE-2024-13903?

No fix has been published for CVE-2024-13903 yet. Limit exposure of the affected software until one is available.

Upgrade to the fixed version. Memory-safe languages, compiler hardening and fuzzing prevent most new cases. More about Memory corruption.

Is CVE-2024-13903 being exploited?

There is no known exploitation of CVE-2024-13903 in the wild and no public exploit code.

Sources

Also known as DEBIAN-CVE-2024-13903, GHSA-phgv-62jq-9jj7.

Is CVE-2024-13903 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free