{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2024-13903 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2024-13903 yet. Limit exposure of the affected software until one is available.","what":"CVE-2024-13903 is a medium-severity memory corruption vulnerability in quickjs-ng QuickJS, published on 21 Mar 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2024-13903 and fix it if it is affected.\n\nWhat it is: CVE-2024-13903 is a medium-severity memory corruption vulnerability in quickjs-ng QuickJS, published on 21 Mar 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2024-13903 in the wild and no public exploit code.\n\nAffected product: quickjs-ng QuickJS. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-13903/ (Markdown: https://insights.sbomify.com/CVE-2024-13903/index.md)","id":"CVE-2024-13903","markdown":"https://insights.sbomify.com/CVE-2024-13903/index.md","name":"CVE-2024-13903","record":{"aliases":["DEBIAN-CVE-2024-13903","GHSA-phgv-62jq-9jj7"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution","denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"JavaScript engine library","requires_auth":"none","summary":"A stack-based buffer overflow in QuickJS allows remote attackers to execute arbitrary code or cause denial of service.","user_interaction":"required","vuln_class":"memory_corruption"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulDB","cpe":[{"product":"quickjs","vendor":"quickjs-ng"}],"cvss":{"score":5.3,"severity":"medium","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-121","name":"Stack-based Buffer Overflow"},{"id":"CWE-787","name":"Out-of-bounds Write"},{"id":"CWE-119","name":"Improper Restriction of Operations within the Bounds of a Memory Buffer"}],"description":"A vulnerability was found in quickjs-ng QuickJS up to 0.8.0. It has been declared as problematic. Affected by this vulnerability is the function JS_GetRuntime of the file quickjs.c of the component qjs. The manipulation leads to stack-based buffer overflow. The attack can be launched remotely. Upgrading to version 0.9.0 is able to address this issue. The patch is named 99c02eb45170775a9a679c32b45dd4000ea67aff. It is recommended to upgrade the affected component.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":false,"headline":"quickjs-ng QuickJS qjs quickjs.c JS_GetRuntime stack-based overflow","id":"CVE-2024-13903","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"memory_corruption","year":"2024"},"n_packages":0,"n_references":6,"next":{"headline":"Platform.ly for WooCommerce \u003c= 1.1.6 - Unauthenticated Blind Server-Side Request Forgery","id":"CVE-2024-13904"},"packages":[],"prev":{"headline":"huang-yk student-manage Edit a Student Information Page cross site scripting","id":"CVE-2024-13902"},"products":["QuickJS"],"published":"2025-03-21","related":[{"cvss_score":6.9,"headline":"quickjs-ng quickjs quickjs.c js_typed_array_constructor heap-based overflow","id":"CVE-2026-0821","kev_date_added":null,"published":"2026-01-10"},{"cvss_score":5.6,"headline":"Memory corruption in QuickJS","id":"CVE-2025-46688","kev_date_added":null,"published":"2025-04-27"},{"cvss_score":5.3,"headline":"quickjs-ng quickjs Atomics Ops quickjs.c use after free","id":"CVE-2026-1144","kev_date_added":null,"published":"2026-01-19"},{"cvss_score":5.3,"headline":"quickjs-ng quickjs quickjs.c js_typed_array_constructor_ta heap-based overflow","id":"CVE-2026-1145","kev_date_added":null,"published":"2026-01-19"},{"cvss_score":5.3,"headline":"quickjs-ng quickjs quickjs.c js_typed_array_sort heap-based overflow","id":"CVE-2026-0822","kev_date_added":null,"published":"2026-01-10"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-03-21","vendors":["quickjs-ng"]},"summary":"A stack-based buffer overflow in QuickJS allows remote attackers to execute arbitrary code or cause denial of service.","url":"https://insights.sbomify.com/CVE-2024-13903/"}