CVE-2024-13914 Path traversal in File Manager Advanced Shortcode
Authenticated administrators can exploit a local file inclusion vulnerability in the File Manager Advanced Shortcode plugin to execute arbitrary JavaScript files.
- Exploited in the wild
- Not known
- Login needed
- An administrator
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- None listed
What is CVE-2024-13914?
CVE-2024-13914 is a high-severity path traversal vulnerability in WP Experts File Manager Advanced Shortcode, published on 15 May 2025. An attacker needs administrator access to exploit it, with no action from the victim.
Official description
The File Manager Advanced Shortcode plugin for WordPress is vulnerable to Local File Inclusion in all versions up to, and including, 2.5.4 (file-manager-advanced-shortcode) and 2.5.6 (advanced-file-manager-pro-premium), via the 'file_manager_advanced' shortcode. This makes it possible for authenticated attackers, with Administrator-level access and above, to include and execute arbitrary JavaScript files on the server. This can be used to bypass access controls, obtain sensitive data, or achieve code execution in cases where images and other “safe” file types can be uploaded and included. Sites currently using 2.5.4 (file-manager-advanced-shortcode) should be updated to 2.6.0 (advanced-file-manager-pro-premium).
Weakness: CWE-22
Which versions are affected by CVE-2024-13914?
How do I fix CVE-2024-13914?
No fix has been published for CVE-2024-13914 yet. Limit exposure of the affected software until one is available.
Upgrade, and resolve every user-supplied path against an allowed base folder before opening it. More about Path traversal.
Is CVE-2024-13914 being exploited?
There is no known exploitation of CVE-2024-13914 in the wild and no public exploit code.
Sources
Also known as GHSA-7chh-jrvc-3cqw.