{"answers":{"affected":"","exploited":"There is no known exploitation of CVE-2024-13914 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2024-13914 yet. Limit exposure of the affected software until one is available.","what":"CVE-2024-13914 is a high-severity path traversal vulnerability in WP Experts File Manager Advanced Shortcode, published on 15 May 2025. An attacker needs administrator access to exploit it, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-13914 and fix it if it is affected.\n\nWhat it is: CVE-2024-13914 is a high-severity path traversal vulnerability in WP Experts File Manager Advanced Shortcode, published on 15 May 2025. An attacker needs administrator access to exploit it, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2024-13914 in the wild and no public exploit code.\n\nAffected product: WP Experts File Manager Advanced Shortcode. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-13914/ (Markdown: https://insights.sbomify.com/CVE-2024-13914/index.md)","id":"CVE-2024-13914","markdown":"https://insights.sbomify.com/CVE-2024-13914/index.md","name":"CVE-2024-13914","record":{"aliases":["GHSA-7chh-jrvc-3cqw"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["code_execution","data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"WordPress plugin","requires_auth":"high_privilege","summary":"Authenticated administrators can exploit a local file inclusion vulnerability in the File Manager Advanced Shortcode plugin to execute arbitrary JavaScript files.","user_interaction":"not_required","vuln_class":"path_traversal"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"Wordfence","cpe":[],"cvss":{"score":7.2,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-22","name":"Improper Limitation of a Pathname to a Restricted Directory"}],"description":"The File Manager Advanced Shortcode plugin for WordPress is vulnerable to Local File Inclusion in all versions up to, and including, 2.5.4 (file-manager-advanced-shortcode) and 2.5.6 (advanced-file-manager-pro-premium), via the 'file_manager_advanced' shortcode. This makes it possible for authenticated attackers, with Administrator-level access and above, to include and execute arbitrary JavaScript files on the server. This can be used to bypass access controls, obtain sensitive data, or achieve code execution in cases where images and other “safe” file types can be uploaded and included. Sites currently using 2.5.4 (file-manager-advanced-shortcode) should be updated to 2.6.0 (advanced-file-manager-pro-premium).","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":null,"headline":"Path traversal in File Manager Advanced Shortcode","id":"CVE-2024-13914","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"path_traversal","year":"2024"},"n_packages":0,"n_references":2,"next":{"headline":"Unrestricted Access to Exported Service in com.pri.factorytest","id":"CVE-2024-13915"},"packages":[],"prev":{"headline":"InstaWP Connect – 1-click WP Staging \u0026 Migration \u003c= 0.1.0.83 - Cross-Site Request Forgery to Local File Inclusion","id":"CVE-2024-13913"},"products":["File Manager Advanced Shortcode"],"published":"2025-05-15","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-04-08","vendors":["WP Experts"]},"summary":"Authenticated administrators can exploit a local file inclusion vulnerability in the File Manager Advanced Shortcode plugin to execute arbitrary JavaScript files.","url":"https://insights.sbomify.com/CVE-2024-13914/"}