# CVE-2024-13914: Path traversal in File Manager Advanced Shortcode

> Authenticated administrators can exploit a local file inclusion vulnerability in the File Manager Advanced Shortcode plugin to execute arbitrary JavaScript files.

- **Severity:** High 7.2 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 15 May 2025
- **Updated:** 8 Apr 2026
- **Also known as:** GHSA-7chh-jrvc-3cqw

## What is CVE-2024-13914?

CVE-2024-13914 is a high-severity path traversal vulnerability in WP Experts File Manager Advanced Shortcode, published on 15 May 2025. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

The File Manager Advanced Shortcode plugin for WordPress is vulnerable to Local File Inclusion in all versions up to, and including, 2.5.4 (file-manager-advanced-shortcode) and 2.5.6 (advanced-file-manager-pro-premium), via the 'file_manager_advanced' shortcode. This makes it possible for authenticated attackers, with Administrator-level access and above, to include and execute arbitrary JavaScript files on the server. This can be used to bypass access controls, obtain sensitive data, or achieve code execution in cases where images and other “safe” file types can be uploaded and included. Sites currently using 2.5.4 (file-manager-advanced-shortcode) should be updated to 2.6.0 (advanced-file-manager-pro-premium).

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2024-13914?


## How do I fix CVE-2024-13914?

No fix has been published for CVE-2024-13914 yet. Limit exposure of the affected software until one is available.

## Is CVE-2024-13914 being exploited?

There is no known exploitation of CVE-2024-13914 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-13914 and fix it if it is affected.

What it is: CVE-2024-13914 is a high-severity path traversal vulnerability in WP Experts File Manager Advanced Shortcode, published on 15 May 2025. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-13914 in the wild and no public exploit code.

Affected product: WP Experts File Manager Advanced Shortcode. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-13914/ (Markdown: https://insights.sbomify.com/CVE-2024-13914/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-13914
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-13914
- OSV: https://osv.dev/vulnerability/CVE-2024-13914

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-13914/
Summaries are generated and may contain mistakes; the official description above is the record.
