{"answers":{"affected":"2 open source packages ship an affected version, including ouch.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-13941 exists.","fix":"Upgrade ouch to 0.4.0 or later.","what":"CVE-2024-13941 is a medium-severity memory corruption vulnerability in ouch-org ouch, published on 1 Apr 2025. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-13941 and fix it if it is affected.\n\nWhat it is: CVE-2024-13941 is a medium-severity memory corruption vulnerability in ouch-org ouch, published on 1 Apr 2025. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-13941 exists.\n\nAffected packages and fixed versions:\n- ouch (crates.io): affected all versions; fixed in 0.4.0\n- ouch (crates.io): affected all versions; fixed in 0.4.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-13941/ (Markdown: https://insights.sbomify.com/CVE-2024-13941/index.md)","id":"CVE-2024-13941","markdown":"https://insights.sbomify.com/CVE-2024-13941/index.md","name":"CVE-2024-13941","record":{"aliases":["GHSA-6xfj-hhwh-r3c2"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution","denial_of_service"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"Rust archive library","requires_auth":"low_privilege","summary":"Local attackers can trigger memory corruption in the ouch archive library via crafted zip date-time data, potentially leading to code execution or crashes.","user_interaction":"not_required","vuln_class":"memory_corruption"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulDB","cpe":[],"cvss":{"score":4.8,"severity":"medium","source":"cna","vector":"CVSS:4.0/AV:L/AC:L/AT:N/PR:L/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-119","name":"Improper Restriction of Operations within the Bounds of a Memory Buffer"}],"description":"A vulnerability was found in ouch-org ouch up to 0.3.1. It has been classified as critical. This affects the function ouch::archive::zip::convert_zip_date_time of the file zip.rs. The manipulation of the argument month leads to memory corruption. The attack needs to be approached locally. The exploit has been disclosed to the public and may be used. Upgrading to version 0.4.0 is able to address this issue. It is recommended to upgrade the affected component.","ecosystems":["crates.io"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"ouch-org ouch zip.rs convert_zip_date_time memory corruption","id":"CVE-2024-13941","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"crates.io","product":null,"products":[],"type":"memory_corruption","year":"2024"},"n_packages":2,"n_references":7,"next":{"headline":"Race condition in RK3588s","id":"CVE-2024-13942"},"packages":[{"ecosystem":"crates.io","fixed":["0.4.0"],"introduced":["0"],"last_affected":[],"package":"ouch","purl":null,"source":"GHSA-6xfj-hhwh-r3c2"},{"ecosystem":"crates.io","fixed":["0.4.0"],"introduced":["0"],"last_affected":[],"package":"ouch","purl":"pkg:cargo/ouch","source":"GHSA-6xfj-hhwh-r3c2"}],"prev":{"headline":"Ninja Forms Webhooks \u003c= 3.0.7 - Authenticated (Admin+) Server-Side Request Forgery via Form Webhook","id":"CVE-2024-13940"},"products":["ouch"],"published":"2025-04-01","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-04-02","vendors":["ouch-org"]},"summary":"Local attackers can trigger memory corruption in the ouch archive library via crafted zip date-time data, potentially leading to code execution or crashes.","url":"https://insights.sbomify.com/CVE-2024-13941/"}