# CVE-2024-13941: ouch-org ouch zip.rs convert_zip_date_time memory corruption

> Local attackers can trigger memory corruption in the ouch archive library via crafted zip date-time data, potentially leading to code execution or crashes.

- **Severity:** Medium 4.8 (`CVSS:4.0/AV:L/AC:L/AT:N/PR:L/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 1 Apr 2025
- **Updated:** 2 Apr 2025
- **Also known as:** GHSA-6xfj-hhwh-r3c2

## What is CVE-2024-13941?

CVE-2024-13941 is a medium-severity memory corruption vulnerability in ouch-org ouch, published on 1 Apr 2025. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

A vulnerability was found in ouch-org ouch up to 0.3.1. It has been classified as critical. This affects the function ouch::archive::zip::convert_zip_date_time of the file zip.rs. The manipulation of the argument month leads to memory corruption. The attack needs to be approached locally. The exploit has been disclosed to the public and may be used. Upgrading to version 0.4.0 is able to address this issue. It is recommended to upgrade the affected component.

Weakness: CWE-119 (Improper Restriction of Operations within the Bounds of a Memory Buffer)

## Which versions are affected by CVE-2024-13941?

2 open source packages ship an affected version, including ouch.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `ouch` | crates.io | All versions | 0.4.0 |
| `ouch` | crates.io | All versions | 0.4.0 |

## How do I fix CVE-2024-13941?

Upgrade ouch to 0.4.0 or later.

## Is CVE-2024-13941 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-13941 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-13941 and fix it if it is affected.

What it is: CVE-2024-13941 is a medium-severity memory corruption vulnerability in ouch-org ouch, published on 1 Apr 2025. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-13941 exists.

Affected packages and fixed versions:
- ouch (crates.io): affected all versions; fixed in 0.4.0
- ouch (crates.io): affected all versions; fixed in 0.4.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-13941/ (Markdown: https://insights.sbomify.com/CVE-2024-13941/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-13941
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-13941
- OSV: https://osv.dev/vulnerability/CVE-2024-13941

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-13941/
Summaries are generated and may contain mistakes; the official description above is the record.
