{"answers":{"affected":"2 open source packages ship an affected version, including tornado.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-14029 exists.","fix":"Upgrade tornado to 6.4.1 or later.","what":"CVE-2024-14029 is a critical vulnerability in tornadoweb tornado, published on 15 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-14029 and fix it if it is affected.\n\nWhat it is: CVE-2024-14029 is a critical vulnerability in tornadoweb tornado, published on 15 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-14029 exists.\n\nAffected packages and fixed versions:\n- tornado (PyPI): affected all versions; fixed in 6.4.1\n- tornado (PyPI): affected all versions; fixed in 6.4.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-14029/ (Markdown: https://insights.sbomify.com/CVE-2024-14029/index.md)","id":"CVE-2024-14029","markdown":"https://insights.sbomify.com/CVE-2024-14029/index.md","name":"CVE-2024-14029","record":{"aliases":["AZL-103101","DEBIAN-CVE-2024-14029","ECHO-d0f5-0786-800c","GHSA-753j-mpmx-qq6g","GHSA-hr42-gv84-2f3g","ROOT-APP-PYPI-GHSA-753j-mpmx-qq6g","UBUNTU-CVE-2024-14029"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["security_bypass","data_modify"],"network_reachable":"yes","non_default_config":false,"product_category":"Python web framework","requires_auth":"none","summary":"Attackers can perform HTTP request smuggling in Tornado by exploiting duplicate Transfer-Encoding headers, leading to access control bypass or cache poisoning.","user_interaction":"not_required","vuln_class":"other"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulnCheck","cpe":[],"cvss":{"score":9,"severity":"critical","source":"cna","vector":"CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:N/VC:L/VI:H/VA:N/SC:L/SI:H/SA:N","version":"4.0"},"cwes":[{"id":"CWE-444","name":"Inconsistent Interpretation of HTTP Requests"}],"description":"Tornado before 6.4.1 ignores duplicate Transfer-Encoding: chunked headers, treating requests as having no message body and parsing the chunked body as a subsequent request. Attackers can exploit this inconsistency when Tornado is deployed behind proxies to perform HTTP request smuggling, enabling access control bypass, cache poisoning, or connection desynchronization.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Tornado before 6.4.1 HTTP Request Smuggling via Transfer-Encoding","id":"CVE-2024-14029","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"other","year":"2024"},"n_packages":2,"n_references":2,"next":{"headline":"Sereal::Decoder versions from 4.000 through 4.009_002 for Perl embeds a vulnerable version of the Zstandard library","id":"CVE-2024-14030"},"packages":[{"ecosystem":"PyPI","fixed":["6.4.1"],"introduced":["0"],"last_affected":[],"package":"tornado","purl":null,"source":"GHSA-753j-mpmx-qq6g"},{"ecosystem":"PyPI","fixed":["6.4.1"],"introduced":["0"],"last_affected":[],"package":"tornado","purl":"pkg:pypi/tornado","source":"GHSA-753j-mpmx-qq6g"}],"prev":{"headline":"Multiple implicit reads in parallel can result in a crash or denial of service","id":"CVE-2024-14028"},"products":["tornado"],"published":"2026-09-15","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-09-15","vendors":["tornadoweb"]},"summary":"Attackers can perform HTTP request smuggling in Tornado by exploiting duplicate Transfer-Encoding headers, leading to access control bypass or cache poisoning.","url":"https://insights.sbomify.com/CVE-2024-14029/"}