# CVE-2024-14029: Tornado before 6.4.1 HTTP Request Smuggling via Transfer-Encoding

> Attackers can perform HTTP request smuggling in Tornado by exploiting duplicate Transfer-Encoding headers, leading to access control bypass or cache poisoning.

- **Severity:** Critical 9.0 (`CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:N/VC:L/VI:H/VA:N/SC:L/SI:H/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 15 Sep 2026
- **Updated:** 15 Sep 2026
- **Also known as:** AZL-103101, DEBIAN-CVE-2024-14029, ECHO-d0f5-0786-800c, GHSA-753j-mpmx-qq6g, GHSA-hr42-gv84-2f3g, ROOT-APP-PYPI-GHSA-753j-mpmx-qq6g, UBUNTU-CVE-2024-14029

## What is CVE-2024-14029?

CVE-2024-14029 is a critical vulnerability in tornadoweb tornado, published on 15 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Tornado before 6.4.1 ignores duplicate Transfer-Encoding: chunked headers, treating requests as having no message body and parsing the chunked body as a subsequent request. Attackers can exploit this inconsistency when Tornado is deployed behind proxies to perform HTTP request smuggling, enabling access control bypass, cache poisoning, or connection desynchronization.

Weakness: CWE-444 (Inconsistent Interpretation of HTTP Requests)

## Which versions are affected by CVE-2024-14029?

2 open source packages ship an affected version, including tornado.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `tornado` | PyPI | All versions | 6.4.1 |
| `tornado` | PyPI | All versions | 6.4.1 |

## How do I fix CVE-2024-14029?

Upgrade tornado to 6.4.1 or later.

## Is CVE-2024-14029 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-14029 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-14029 and fix it if it is affected.

What it is: CVE-2024-14029 is a critical vulnerability in tornadoweb tornado, published on 15 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-14029 exists.

Affected packages and fixed versions:
- tornado (PyPI): affected all versions; fixed in 6.4.1
- tornado (PyPI): affected all versions; fixed in 6.4.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-14029/ (Markdown: https://insights.sbomify.com/CVE-2024-14029/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-14029
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-14029
- OSV: https://osv.dev/vulnerability/CVE-2024-14029

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-14029/
Summaries are generated and may contain mistakes; the official description above is the record.
