CVE-2024-14042 Open5GS Diameter S6a hss-s6a-path.c hss_ogs_diam_s6a_ulr_cb stack-based overflow

Medium 5.3 Published Updated

Remote attackers can trigger a stack-based buffer overflow in Open5GS Diameter S6a interface, potentially leading to code execution or service disruption.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
None listed

What is CVE-2024-14042?

CVE-2024-14042 is a medium-severity memory corruption vulnerability in Open5GS, published on 11 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

A vulnerability was found in Open5GS up to 2.7.1. This affects the function hss_ogs_diam_s6a_air_cb/hss_ogs_diam_s6a_ulr_cb of the file src/hss/hss-s6a-path.c of the component Diameter S6a Interface. Performing a manipulation of the argument os.len results in stack-based buffer overflow. It is possible to initiate the attack remotely. The exploit has been made public and could be used. Upgrading to version 2.7.2 is able to mitigate this issue. The patch is named e89aa79efe629ae90f59dcdf8847c117d9a7da86. It is suggested to upgrade the affected component.

Weakness: CWE-121, CWE-119

Which versions are affected by CVE-2024-14042?

How do I fix CVE-2024-14042?

No fix has been published for CVE-2024-14042 yet. Limit exposure of the affected software until one is available.

Upgrade to the fixed version. Memory-safe languages, compiler hardening and fuzzing prevent most new cases. More about Memory corruption.

Is CVE-2024-14042 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-14042 exists.

Sources

Also known as GHSA-82w6-qmfj-h49g.

Is CVE-2024-14042 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free