# CVE-2024-14044: Open5GS Diameter Rx pcrf-rx-path.c pcrf_rx_aar_cb buffer overflow

> Remote attackers can trigger a buffer overflow in Open5GS Diameter Rx handler, potentially leading to code execution or service disruption.

- **Severity:** Medium 5.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N/E:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 12 Aug 2026
- **Updated:** 12 Aug 2026
- **Also known as:** GHSA-pgwr-38c3-f9pj

## What is CVE-2024-14044?

CVE-2024-14044 is a medium-severity memory corruption vulnerability in Open5GS, published on 12 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

A vulnerability was identified in Open5GS up to 2.7.1. This issue affects the function pcrf_rx_aar_cb of the file src/pcrf/pcrf-rx-path.c of the component Diameter Rx Handler. The manipulation of the argument num_of_media_component/num_of_sub leads to buffer overflow. The attack can be initiated remotely. The exploit is publicly available and might be used. Upgrading to version 2.7.2 is capable of addressing this issue. The identifier of the patch is 87b4e4535c77ded627cdb6f4e4e2e3ea761f40b7. It is recommended to upgrade the affected component.

Weakness: CWE-120 (Buffer Copy without Checking Size of Input), CWE-119 (Improper Restriction of Operations within the Bounds of a Memory Buffer)

## Which versions are affected by CVE-2024-14044?


## How do I fix CVE-2024-14044?

No fix has been published for CVE-2024-14044 yet. Limit exposure of the affected software until one is available.

## Is CVE-2024-14044 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-14044 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-14044 and fix it if it is affected.

What it is: CVE-2024-14044 is a medium-severity memory corruption vulnerability in Open5GS, published on 12 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-14044 exists.

Affected product: Open5GS. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-14044/ (Markdown: https://insights.sbomify.com/CVE-2024-14044/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-14044
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-14044
- OSV: https://osv.dev/vulnerability/CVE-2024-14044

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-14044/
Summaries are generated and may contain mistakes; the official description above is the record.
