CVE-2024-1412 Memberpress <= 1.11.24 - Reflected Cross-Site Scripting via message and error
Unauthenticated attackers can inject arbitrary web scripts via message and error parameters, executing code in victim browsers.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- None listed
What is CVE-2024-1412?
CVE-2024-1412 is a medium-severity cross-site scripting vulnerability in Memberpress, published on 9 Apr 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
The Memberpress plugin for WordPress is vulnerable to Reflected Cross-Site Scripting via the ‘message’ and 'error' parameters in all versions up to, and including, 1.11.26 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that execute if they can successfully trick a user into performing an action such as clicking on a link. Note - the issue was partially patched in 1.11.25, but could still potentially be exploited under some circumstances.
Weakness: CWE-79
Which versions are affected by CVE-2024-1412?
It affects 1 product.
Products include Caseproof Memberpress.
How do I fix CVE-2024-1412?
No fix has been published for CVE-2024-1412 yet. Limit exposure of the affected software until one is available.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2024-1412 being exploited?
There is no known exploitation of CVE-2024-1412 in the wild and no public exploit code.
Other vulnerabilities in Memberpress
- CVE-2024-5031 MemberPress <= 1.11.29 - Authenticated (Contributor+) Blind Server-Side Request Forgery via mepr-user-file Shortcode
- CVE-2024-43956 WordPress MemberPress plugin <= 1.11.34 - Broken Access Control vulnerability
- CVE-2024-5025 MemberPress <= 1.11.29 - Authenticated (Contributor+) Stored Cross-Site Scripting via arglist Parameter
- CVE-2024-11299 Memberpress <= 1.11.37 - Unauthenticated Content Restriction Bypass to Sensitive Information Exposure
Sources
Also known as GHSA-h28q-32f7-jxrv.