# CVE-2024-1412: Memberpress <= 1.11.24 - Reflected Cross-Site Scripting via message and error

> Unauthenticated attackers can inject arbitrary web scripts via message and error parameters, executing code in victim browsers.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 9 Apr 2024
- **Updated:** 8 Apr 2026
- **Also known as:** GHSA-h28q-32f7-jxrv

## What is CVE-2024-1412?

CVE-2024-1412 is a medium-severity cross-site scripting vulnerability in Memberpress, published on 9 Apr 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

The Memberpress plugin for WordPress is vulnerable to Reflected Cross-Site Scripting via the ‘message’ and 'error' parameters in all versions up to, and including, 1.11.26 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that execute if they can successfully trick a user into performing an action such as clicking on a link. Note - the issue was partially patched in 1.11.25, but could still potentially be exploited under some circumstances.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2024-1412?

It affects 1 product.


Products: Caseproof Memberpress.

## How do I fix CVE-2024-1412?

No fix has been published for CVE-2024-1412 yet. Limit exposure of the affected software until one is available.

## Is CVE-2024-1412 being exploited?

There is no known exploitation of CVE-2024-1412 in the wild and no public exploit code.

## Other vulnerabilities in Memberpress

- [CVE-2024-5031](https://insights.sbomify.com/CVE-2024-5031/): MemberPress <= 1.11.29 - Authenticated (Contributor+) Blind Server-Side Request Forgery via mepr-user-file Shortcode (high 8.5)
- [CVE-2024-43956](https://insights.sbomify.com/CVE-2024-43956/): WordPress MemberPress plugin <= 1.11.34 - Broken Access Control vulnerability (medium 6.5)
- [CVE-2024-5025](https://insights.sbomify.com/CVE-2024-5025/): MemberPress <= 1.11.29 - Authenticated (Contributor+) Stored Cross-Site Scripting via arglist Parameter (medium 6.4)
- [CVE-2024-11299](https://insights.sbomify.com/CVE-2024-11299/): Memberpress <= 1.11.37 - Unauthenticated Content Restriction Bypass to Sensitive Information Exposure (medium 5.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-1412 and fix it if it is affected.

What it is: CVE-2024-1412 is a medium-severity cross-site scripting vulnerability in Memberpress, published on 9 Apr 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2024-1412 in the wild and no public exploit code.

Affected product: Memberpress. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-1412/ (Markdown: https://insights.sbomify.com/CVE-2024-1412/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-1412
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-1412
- OSV: https://osv.dev/vulnerability/CVE-2024-1412

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-1412/
Summaries are generated and may contain mistakes; the official description above is the record.
