{"answers":{"affected":"3 open source packages ship an affected version, including moodle/moodle and moodle. It affects 1 product.","exploited":"There is no known exploitation of CVE-2024-1439 in the wild and no public exploit code.","fix":"Apply the vendor's patch.","what":"CVE-2024-1439 is a medium-severity missing authorization vulnerability in Moodle Moodle, published on 12 Feb 2024. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-1439 and fix it if it is affected.\n\nWhat it is: CVE-2024-1439 is a medium-severity missing authorization vulnerability in Moodle Moodle, published on 12 Feb 2024. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2024-1439 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- moodle/moodle (Packagist): affected all versions up to 4.2.0; no fix listed\n- moodle/moodle (Packagist): affected all versions up to 4.2.0; no fix listed\n- moodle (Bitnami): affected all versions; fixed in 4.3.4\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-1439/ (Markdown: https://insights.sbomify.com/CVE-2024-1439/index.md)","id":"CVE-2024-1439","markdown":"https://insights.sbomify.com/CVE-2024-1439/index.md","name":"CVE-2024-1439","record":{"aliases":["BIT-moodle-2024-1439","GHSA-5p2x-8427-9fgp","UBUNTU-CVE-2024-1439"],"analysis":{"component_type":"web_application","fix_type":"patch","impacts":["data_modify","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Moodle LMS","requires_auth":"low_privilege","summary":"Students can create arbitrary calendar events for higher-privilege users and all users without consent due to inadequate access control.","user_interaction":"not_required","vuln_class":"missing_authorization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"INCIBE","cpe":[{"product":"moodle","vendor":"moodle"}],"cvss":{"score":6.5,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N","version":"3.1"},"cwes":[{"id":"CWE-284","name":"Improper Access Control"}],"description":"Inadequate access control in Moodle LMS. This vulnerability could allow a local user with a student role to create arbitrary events intended for users with higher roles. It could also allow the attacker to add events to the calendar of all users without their prior consent.","ecosystems":["Bitnami","Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Inadequate access control vulnerability in Moodle","id":"CVE-2024-1439","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":"moodle:moodle","products":["moodle:moodle"],"type":"missing_authorization","year":"2024"},"n_packages":3,"n_references":1,"next":{"headline":"Open Redirection in Multiple WSO2 Products via Multi-Option Authentication Endpoint","id":"CVE-2024-1440"},"packages":[{"ecosystem":"Bitnami","fixed":["4.3.4"],"introduced":["0"],"last_affected":[],"package":"moodle","purl":"pkg:bitnami/moodle","source":"BIT-moodle-2024-1439"},{"ecosystem":"Packagist","fixed":[],"introduced":["0"],"last_affected":["4.2.0"],"package":"moodle/moodle","purl":null,"source":"GHSA-5p2x-8427-9fgp"},{"ecosystem":"Packagist","fixed":[],"introduced":["0"],"last_affected":["4.2.0"],"package":"moodle/moodle","purl":"pkg:composer/moodle/moodle","source":"GHSA-5p2x-8427-9fgp"}],"prev":{"headline":"WordPress Rolo Slider plugin \u003c= 1.0.9 - Broken Access Control vulnerability","id":"CVE-2024-1438"},"products":["LMS"],"published":"2024-02-12","related":[{"cvss_score":10,"headline":"File upload in n/a","id":"CVE-2006-4935","kev_date_added":null,"published":"2006-09-23"},{"cvss_score":10,"headline":"Moodle does not properly validate module instance id","id":"CVE-2006-4936","kev_date_added":null,"published":"2006-09-23"},{"cvss_score":10,"headline":"Unknown \"front page vulnerability with Moodle servers\" for Moodle before 1.3.2 has unknown impact and attack vectors.","id":"CVE-2004-2233","kev_date_added":null,"published":"2005-07-17"},{"cvss_score":10,"headline":"Cross-site scripting in n/a","id":"CVE-2004-2235","kev_date_added":null,"published":"2005-07-17"},{"cvss_score":10,"headline":"Other in n/a","id":"CVE-2004-2236","kev_date_added":null,"published":"2005-07-17"},{"cvss_score":10,"headline":"Unknown vulnerability in Moodle before 1.3.4 has unknown impact and attack vectors, related to \"strings in Moodle texts.\"","id":"CVE-2004-2237","kev_date_added":null,"published":"2005-07-17"},{"cvss_score":10,"headline":"Multiple unknown vulnerabilities in Moodle before 1.5.1 have unknown impact and attack vectors.","id":"CVE-2005-2247","kev_date_added":null,"published":"2005-07-12"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-08-01","vendors":["Moodle"]},"summary":"Students can create arbitrary calendar events for higher-privilege users and all users without consent due to inadequate access control.","url":"https://insights.sbomify.com/CVE-2024-1439/"}