{"answers":{"affected":"3 open source packages ship an affected version, including langchain-core. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-1455 exists.","fix":"Upgrade langchain-core to 0.1.35 or later.","what":"CVE-2024-1455 is a medium-severity denial of service vulnerability in langchain-ai/langchain, published on 26 Mar 2024. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-1455 and fix it if it is affected.\n\nWhat it is: CVE-2024-1455 is a medium-severity denial of service vulnerability in langchain-ai/langchain, published on 26 Mar 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-1455 exists.\n\nAffected packages and fixed versions:\n- langchain-core (PyPI): affected all versions; fixed in 0.1.35\n- langchain-core (PyPI): affected all versions; fixed in 0.1.35\n- langchain-core (PyPI): affected all versions; fixed in 0.1.35\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-1455/ (Markdown: https://insights.sbomify.com/CVE-2024-1455/index.md)","id":"CVE-2024-1455","markdown":"https://insights.sbomify.com/CVE-2024-1455/index.md","name":"CVE-2024-1455","record":{"aliases":["GHSA-q84m-rmw3-4382","PYSEC-2026-1519"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Python LLM framework","requires_auth":"none","summary":"An attacker can cause a denial of service in the LangChain library by submitting a malicious XML document that triggers excessive resource consumption.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"@huntr_ai","cpe":[{"product":"langchain","vendor":"langchain"}],"cvss":{"score":5.9,"severity":"medium","source":"cna","vector":"CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.0"},"cwes":[{"id":"CWE-776","name":"Improper Restriction of Recursive Entity References in DTDs"}],"description":"A vulnerability in the langchain-ai/langchain repository allows for a Billion Laughs Attack, a type of XML External Entity (XXE) exploitation. By nesting multiple layers of entities within an XML document, an attacker can cause the XML parser to consume excessive CPU and memory resources, leading to a denial of service (DoS).","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Billion Laughs Attack leading to DoS in langchain-ai/langchain","id":"CVE-2024-1455","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"denial_of_service","year":"2024"},"n_packages":3,"n_references":2,"next":{"headline":"S3 Bucket Takeover in h2oai/h2o-3","id":"CVE-2024-1456"},"packages":[{"ecosystem":"PyPI","fixed":["0.1.35"],"introduced":["0"],"last_affected":[],"package":"langchain-core","purl":null,"source":"GHSA-q84m-rmw3-4382"},{"ecosystem":"PyPI","fixed":["0.1.35"],"introduced":["0"],"last_affected":[],"package":"langchain-core","purl":"pkg:pypi/langchain-core","source":"GHSA-q84m-rmw3-4382"},{"ecosystem":"PyPI","fixed":["0.1.35"],"introduced":["0"],"last_affected":[],"package":"langchain-core","purl":"pkg:pypi/langchain-core","source":"PYSEC-2026-1519"}],"prev":{"headline":"Opensc: memory use after free in authentic driver when updating token info","id":"CVE-2024-1454"},"products":["langchain-ai/langchain"],"published":"2024-03-26","related":[{"cvss_score":9.8,"headline":"Langchain vulnerable to arbitrary code execution via the evaluate function in the numexpr library","id":"CVE-2023-39631","kev_date_added":null,"published":"2023-09-01"},{"cvss_score":9.8,"headline":"langchain vulnerable to arbitrary code execution","id":"CVE-2023-36281","kev_date_added":null,"published":"2023-08-22"},{"cvss_score":9.8,"headline":"LangChain vulnerable to arbitrary code execution","id":"CVE-2023-38860","kev_date_added":null,"published":"2023-08-15"},{"cvss_score":9.8,"headline":"LangChain vulnerable to arbitrary code execution","id":"CVE-2023-38896","kev_date_added":null,"published":"2023-08-15"},{"cvss_score":9.8,"headline":"LangChain vulnerable to arbitrary code execution","id":"CVE-2023-39659","kev_date_added":null,"published":"2023-08-15"},{"cvss_score":9.8,"headline":"langchain Code Injection vulnerability","id":"CVE-2023-36095","kev_date_added":null,"published":"2023-08-05"},{"cvss_score":9.8,"headline":"langchain vulnerable to arbitrary code execution","id":"CVE-2023-36188","kev_date_added":null,"published":"2023-07-06"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-08-15","vendors":["langchain-ai"]},"summary":"An attacker can cause a denial of service in the LangChain library by submitting a malicious XML document that triggers excessive resource consumption.","url":"https://insights.sbomify.com/CVE-2024-1455/"}