# CVE-2024-1455: Billion Laughs Attack leading to DoS in langchain-ai/langchain

> An attacker can cause a denial of service in the LangChain library by submitting a malicious XML document that triggers excessive resource consumption.

- **Severity:** Medium 5.9 (`CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 26 Mar 2024
- **Updated:** 15 Aug 2024
- **Also known as:** GHSA-q84m-rmw3-4382, PYSEC-2026-1519

## What is CVE-2024-1455?

CVE-2024-1455 is a medium-severity denial of service vulnerability in langchain-ai/langchain, published on 26 Mar 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

A vulnerability in the langchain-ai/langchain repository allows for a Billion Laughs Attack, a type of XML External Entity (XXE) exploitation. By nesting multiple layers of entities within an XML document, an attacker can cause the XML parser to consume excessive CPU and memory resources, leading to a denial of service (DoS).

Weakness: CWE-776 (Improper Restriction of Recursive Entity References in DTDs)

## Which versions are affected by CVE-2024-1455?

3 open source packages ship an affected version, including langchain-core. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `langchain-core` | PyPI | All versions | 0.1.35 |
| `langchain-core` | PyPI | All versions | 0.1.35 |
| `langchain-core` | PyPI | All versions | 0.1.35 |

Products: Langchain Langchain.

## How do I fix CVE-2024-1455?

Upgrade langchain-core to 0.1.35 or later.

## Is CVE-2024-1455 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-1455 exists.

## Other vulnerabilities in langchain-ai/langchain

- [CVE-2023-39631](https://insights.sbomify.com/CVE-2023-39631/): Langchain vulnerable to arbitrary code execution via the evaluate function in the numexpr library (critical 9.8)
- [CVE-2023-36281](https://insights.sbomify.com/CVE-2023-36281/): langchain vulnerable to arbitrary code execution (critical 9.8)
- [CVE-2023-38860](https://insights.sbomify.com/CVE-2023-38860/): LangChain vulnerable to arbitrary code execution (critical 9.8)
- [CVE-2023-38896](https://insights.sbomify.com/CVE-2023-38896/): LangChain vulnerable to arbitrary code execution (critical 9.8)
- [CVE-2023-39659](https://insights.sbomify.com/CVE-2023-39659/): LangChain vulnerable to arbitrary code execution (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-1455 and fix it if it is affected.

What it is: CVE-2024-1455 is a medium-severity denial of service vulnerability in langchain-ai/langchain, published on 26 Mar 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-1455 exists.

Affected packages and fixed versions:
- langchain-core (PyPI): affected all versions; fixed in 0.1.35
- langchain-core (PyPI): affected all versions; fixed in 0.1.35
- langchain-core (PyPI): affected all versions; fixed in 0.1.35

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-1455/ (Markdown: https://insights.sbomify.com/CVE-2024-1455/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-1455
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-1455
- OSV: https://osv.dev/vulnerability/CVE-2024-1455

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-1455/
Summaries are generated and may contain mistakes; the official description above is the record.
