CVE-2024-1493 Uncontrolled Resource Consumption in GitLab

Medium 6.5 Published Updated

Attackers can cause server denial of service via ReDoS in dependency file link generation, requiring GitLab upgrades.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2024-1493?

CVE-2024-1493 is a medium-severity denial of service vulnerability in Gitlab Gitlab, published on 26 Jun 2024. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

An issue was discovered in GitLab CE/EE affecting all versions starting from 9.2 prior to 16.11.5, starting from 17.0 prior to 17.0.3, and starting from 17.1 prior to 17.1.1, with the processing logic for generating link in dependency files can lead to a regular expression DoS attack on the server

Weakness: CWE-1333

Which versions are affected by CVE-2024-1493?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiFrom 9.2.016.11.5, 17.0.3, 17.1.1

Products include Gitlab Gitlab.

How do I fix CVE-2024-1493?

Upgrade gitlab to a fixed version for your release line: 16.11.5, 17.0.3 or 17.1.1.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2024-1493 being exploited?

There is no known exploitation of CVE-2024-1493 in the wild and no public exploit code.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2024-1493, GHSA-c3ph-4hj5-r598, UBUNTU-CVE-2024-1493.

Is CVE-2024-1493 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free