CVE-2024-1495 Uncontrolled Resource Consumption in GitLab
An attacker can cause a denial of service in GitLab by uploading a maliciously crafted file, requiring an upgrade to patched versions.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2024-1495?
CVE-2024-1495 is a medium-severity denial of service vulnerability in Gitlab Gitlab, published on 12 Jun 2024. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
An issue has been discovered in GitLab CE/EE affecting all versions starting from 13.1 prior to 16.10.7, starting from 16.11 prior to 16.11.4, and starting from 17.0 prior to 17.0.2. It was possible for an attacker to cause a denial of service using maliciously crafted file.
Weakness: CWE-1333
Which versions are affected by CVE-2024-1495?
1 open source package ship an affected version, including gitlab. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
gitlab Bitnami | From 13.1.0 | 16.10.7, 16.11.4, 17.0.2 |
Products include Gitlab Gitlab.
How do I fix CVE-2024-1495?
Upgrade gitlab to a fixed version for your release line: 16.10.7, 16.11.4 or 17.0.2.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2024-1495 being exploited?
There is no known exploitation of CVE-2024-1495 in the wild and no public exploit code.
Other vulnerabilities in Gitlab Gitlab
- CVE-2026-97229 GitLab Community Edition and Enterprise Edition Integer Overflow or Wraparound
- CVE-2026-85706 GitLab Community Edition and Enterprise Edition Path Traversal
- CVE-2023-7028 GitLab Community and Enterprise Editions Improper Access Control
- CVE-2021-22205 GitLab Community and Enterprise Editions Remote Code Execution
- CVE-2021-39935 GitLab Community and Enterprise Editions Server-Side Request Forgery (SSRF)
Sources
Also known as BIT-gitlab-2024-1495, GHSA-8372-vr6c-f48r, UBUNTU-CVE-2024-1495.