# CVE-2024-1558: Path Traversal Vulnerability in mlflow/mlflow

> Attackers can read arbitrary files on the server by exploiting a path traversal flaw in the model version creation handler.

- **Severity:** High 7.5 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 16 Apr 2024
- **Updated:** 1 Aug 2024
- **Also known as:** BIT-mlflow-2024-1558, GHSA-j62r-wxqq-f3gf, PYSEC-2026-1653

## What is CVE-2024-1558?

CVE-2024-1558 is a high-severity path traversal vulnerability in Lfprojects Mlflow, published on 16 Apr 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

A path traversal vulnerability exists in the `_create_model_version()` function within `server/handlers.py` of the mlflow/mlflow repository, due to improper validation of the `source` parameter. Attackers can exploit this vulnerability by crafting a `source` parameter that bypasses the `_validate_non_local_source_contains_relative_paths(source)` function's checks, allowing for arbitrary file read access on the server. The issue arises from the handling of unquoted URL characters and the subsequent misuse of the original `source` value for model version creation, leading to the exposure of sensitive files when interacting with the `/model-versions/get-artifact` handler.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2024-1558?

4 open source packages ship an affected version, including mlflow. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mlflow` | Bitnami | All versions | 2.12.1 |
| `mlflow` | PyPI | All versions | 2.12.1 |
| `mlflow` | PyPI | All versions | 2.12.1 |
| `mlflow` | PyPI | All versions | 2.12.1 |

Products: Lfprojects Mlflow.

## How do I fix CVE-2024-1558?

Upgrade mlflow to 2.12.1 or later.

## Is CVE-2024-1558 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-1558 exists.

## Other vulnerabilities in Lfprojects Mlflow

- [CVE-2026-64849](https://insights.sbomify.com/CVE-2026-64849/): MLflow Server-Side Request Forgery (critical 9.3, exploited in the wild)
- [CVE-2025-15379](https://insights.sbomify.com/CVE-2025-15379/): Command Injection in mlflow/mlflow (critical 10.0)
- [CVE-2024-0520](https://insights.sbomify.com/CVE-2024-0520/): Remote Code Execution due to Full Controlled File Write in mlflow/mlflow (critical 10.0)
- [CVE-2023-6977](https://insights.sbomify.com/CVE-2023-6977/): Path Traversal: '\..\filename' (critical 10.0)
- [CVE-2023-6709](https://insights.sbomify.com/CVE-2023-6709/): Improper Neutralization of Special Elements Used in a Template Engine in mlflow/mlflow (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-1558 and fix it if it is affected.

What it is: CVE-2024-1558 is a high-severity path traversal vulnerability in Lfprojects Mlflow, published on 16 Apr 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-1558 exists.

Affected packages and fixed versions:
- mlflow (Bitnami): affected all versions; fixed in 2.12.1
- mlflow (PyPI): affected all versions; fixed in 2.12.1
- mlflow (PyPI): affected all versions; fixed in 2.12.1
- mlflow (PyPI): affected all versions; fixed in 2.12.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-1558/ (Markdown: https://insights.sbomify.com/CVE-2024-1558/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-1558
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-1558
- OSV: https://osv.dev/vulnerability/CVE-2024-1558

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-1558/
Summaries are generated and may contain mistakes; the official description above is the record.
