# CVE-2024-1560: Path Traversal Vulnerability in mlflow/mlflow

> Attackers can delete arbitrary directories on the server filesystem by exploiting path traversal in MLflow's artifact deletion handler.

- **Severity:** High 8.1 (`CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 16 Apr 2024
- **Updated:** 9 Aug 2024
- **Also known as:** BIT-mlflow-2024-1560, GHSA-5mvj-wmgj-7q8c, PYSEC-2026-1641

## What is CVE-2024-1560?

CVE-2024-1560 is a high-severity path traversal vulnerability in Lfprojects Mlflow, published on 16 Apr 2024. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

A path traversal vulnerability exists in the mlflow/mlflow repository, specifically within the artifact deletion functionality. Attackers can bypass path validation by exploiting the double decoding process in the `_delete_artifact_mlflow_artifacts` handler and `local_file_uri_to_path` function, allowing for the deletion of arbitrary directories on the server's filesystem. This vulnerability is due to an extra unquote operation in the `delete_artifacts` function of `local_artifact_repo.py`, which fails to properly sanitize user-supplied paths. The issue is present up to version 2.9.2, despite attempts to fix a similar issue in CVE-2023-6831.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2024-1560?

4 open source packages ship an affected version, including mlflow. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mlflow` | Bitnami | All versions | 2.12.2 |
| `mlflow` | PyPI | All versions to 2.9.2 | None |
| `mlflow` | PyPI | All versions to 2.9.2 | None |
| `mlflow` | PyPI | All versions to 2.9.2 | None |

Products: Lfprojects Mlflow.

## How do I fix CVE-2024-1560?

Upgrade mlflow to 2.12.2 or later.

## Is CVE-2024-1560 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-1560 exists.

## Other vulnerabilities in Lfprojects Mlflow

- [CVE-2026-64849](https://insights.sbomify.com/CVE-2026-64849/): MLflow Server-Side Request Forgery (critical 9.3, exploited in the wild)
- [CVE-2025-15379](https://insights.sbomify.com/CVE-2025-15379/): Command Injection in mlflow/mlflow (critical 10.0)
- [CVE-2024-0520](https://insights.sbomify.com/CVE-2024-0520/): Remote Code Execution due to Full Controlled File Write in mlflow/mlflow (critical 10.0)
- [CVE-2023-6977](https://insights.sbomify.com/CVE-2023-6977/): Path Traversal: '\..\filename' (critical 10.0)
- [CVE-2023-6709](https://insights.sbomify.com/CVE-2023-6709/): Improper Neutralization of Special Elements Used in a Template Engine in mlflow/mlflow (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-1560 and fix it if it is affected.

What it is: CVE-2024-1560 is a high-severity path traversal vulnerability in Lfprojects Mlflow, published on 16 Apr 2024. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-1560 exists.

Affected packages and fixed versions:
- mlflow (Bitnami): affected all versions; fixed in 2.12.2
- mlflow (PyPI): affected all versions up to 2.9.2; no fix listed
- mlflow (PyPI): affected all versions up to 2.9.2; no fix listed
- mlflow (PyPI): affected all versions up to 2.9.2; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-1560/ (Markdown: https://insights.sbomify.com/CVE-2024-1560/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-1560
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-1560
- OSV: https://osv.dev/vulnerability/CVE-2024-1560

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-1560/
Summaries are generated and may contain mistakes; the official description above is the record.
