# CVE-2024-1561: Arbitrary Local File Read via Component Method Invocation in gradio-app/gradio

> Attackers can read arbitrary local files via the component server endpoint, exposing sensitive data like API keys.

- **Severity:** High 7.5 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 16 Apr 2024
- **Updated:** 13 Feb 2025
- **Also known as:** CVE-2024-34511, GHSA-g9cj-cfpp-4g2x, PYSEC-2026-1415

## What is CVE-2024-1561?

CVE-2024-1561 is a high-severity path traversal vulnerability in Gradio Project Gradio, published on 16 Apr 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

An issue was discovered in gradio-app/gradio, where the `/component_server` endpoint improperly allows the invocation of any method on a `Component` class with attacker-controlled arguments. Specifically, by exploiting the `move_resource_to_block_cache()` method of the `Block` class, an attacker can copy any file on the filesystem to a temporary directory and subsequently retrieve it. This vulnerability enables unauthorized local file read access, posing a significant risk especially when the application is exposed to the internet via `launch(share=True)`, thereby allowing remote attackers to read files on the host machine. Furthermore, gradio apps hosted on `huggingface.co` are also affected, potentially leading to the exposure of sensitive information such as API keys and credentials stored in environment variables.

Weakness: CWE-29 (Path Traversal: '\..\filename')

## Which versions are affected by CVE-2024-1561?

3 open source packages ship an affected version, including gradio. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `gradio` | PyPI | All versions | 4.13.0 |
| `gradio` | PyPI | All versions | 4.13.0 |
| `gradio` | PyPI | All versions | 4.13.0 |

Products: Gradio Project Gradio.

## How do I fix CVE-2024-1561?

Upgrade gradio to 4.13.0 or later.

## Is CVE-2024-1561 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-1561 exists.

Public exploit code:

- Poc for CVE-2024-1561 affecting Gradio 4.12.0 (github_poc): https://github.com/DiabloHTB/CVE-2024-1561
- Nuclei Templates  (github_poc): https://github.com/DiabloHTB/Nuclei-Template-CVE-2024-1561
- HDU IS Work 1 - secure REST API, CI/CD security pipeline, CVE-2024-1561 remediation (github_poc): https://github.com/WeiTao712/hdu-is-work1
- Information Security Lab 1: secure REST API, CI security scans, and CVE-2024-1561 analysis (github_poc): https://github.com/ImYangC7/hdu-is-lab1
- Gradio 4.3-4.12 - Local File Read (nuclei): http/cves/2024/CVE-2024-1561.yaml

## Other vulnerabilities in Gradio Project Gradio

- [CVE-2024-39236](https://insights.sbomify.com/CVE-2024-39236/): Withdrawn Advisory: Gradio was discovered to contain a code injection vulnerability via the component /gradio/component_meta.py (critical 9.8)
- [CVE-2023-6572](https://insights.sbomify.com/CVE-2023-6572/): Command Injection in gradio-app/gradio (critical 9.6)
- [CVE-2022-24770](https://insights.sbomify.com/CVE-2022-24770/): Improper Neutralization of Formula Elements in a CSV File in Gradio Flagging (high 8.8)
- [CVE-2026-49119](https://insights.sbomify.com/CVE-2026-49119/): Gradio < 6.16.0 Path Traversal via FileExplorer.preprocess() (high 8.7)
- [CVE-2025-23042](https://insights.sbomify.com/CVE-2025-23042/): Gradio Blocked Path ACL Bypass Vulnerability (high 8.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-1561 and fix it if it is affected.

What it is: CVE-2024-1561 is a high-severity path traversal vulnerability in Gradio Project Gradio, published on 16 Apr 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-1561 exists.

Affected packages and fixed versions:
- gradio (PyPI): affected all versions; fixed in 4.13.0
- gradio (PyPI): affected all versions; fixed in 4.13.0
- gradio (PyPI): affected all versions; fixed in 4.13.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-1561/ (Markdown: https://insights.sbomify.com/CVE-2024-1561/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-1561
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-1561
- OSV: https://osv.dev/vulnerability/CVE-2024-1561

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-1561/
Summaries are generated and may contain mistakes; the official description above is the record.
