# CVE-2024-1562: WooCommerce Google Sheet Connector <= 1.3.11 - Missing Authorization

> Unauthenticated attackers can modify plugin settings due to a missing capability check in the WooCommerce Google Sheet Connector plugin.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 21 Feb 2024
- **Updated:** 8 Apr 2026
- **Also known as:** GHSA-wqjf-rx4g-qxmr

## What is CVE-2024-1562?

CVE-2024-1562 is a medium-severity missing authorization vulnerability in westerndeal GSheetConnector for WooCommerce – Send your Orders and Products to Google Sheet in Real-Time, published on 21 Feb 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The WooCommerce Google Sheet Connector plugin for WordPress is vulnerable to unauthorized modification of data due to a missing capability check on the execute_post_data function in all versions up to, and including, 1.3.11. This makes it possible for unauthenticated attackers to update plugin settings.

Weakness: CWE-862 (Missing Authorization)

## Which versions are affected by CVE-2024-1562?

It affects 1 product.


Products: Gsheetconnector Woocommerce Google Sheet Connector.

## How do I fix CVE-2024-1562?

No fix has been published for CVE-2024-1562 yet. Limit exposure of the affected software until one is available.

## Is CVE-2024-1562 being exploited?

There is no known exploitation of CVE-2024-1562 in the wild and no public exploit code.

## Other vulnerabilities in westerndeal GSheetConnector for WooCommerce – Send your Orders and Products to Google Sheet in Real-Time

- [CVE-2023-2329](https://insights.sbomify.com/CVE-2023-2329/): WooCommerce Google Sheet Connector < 1.3.6 - Access Code Update via CSRF (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-1562 and fix it if it is affected.

What it is: CVE-2024-1562 is a medium-severity missing authorization vulnerability in westerndeal GSheetConnector for WooCommerce – Send your Orders and Products to Google Sheet in Real-Time, published on 21 Feb 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-1562 in the wild and no public exploit code.

Affected product: westerndeal GSheetConnector for WooCommerce – Send your Orders and Products to Google Sheet in Real-Time. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-1562/ (Markdown: https://insights.sbomify.com/CVE-2024-1562/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-1562
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-1562
- OSV: https://osv.dev/vulnerability/CVE-2024-1562

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-1562/
Summaries are generated and may contain mistakes; the official description above is the record.
