# CVE-2024-1593: Path Traversal via Parameter Smuggling in mlflow/mlflow

> Attackers can exploit path traversal via URL parameter smuggling to access unauthorized files or compromise the server.

- **Severity:** High 7.5 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 16 Apr 2024
- **Updated:** 1 Aug 2024
- **Also known as:** BIT-mlflow-2024-1593, GHSA-f42m-mvfv-cgw5, PYSEC-2026-1649

## What is CVE-2024-1593?

CVE-2024-1593 is a high-severity path traversal vulnerability in Lfprojects Mlflow, published on 16 Apr 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

A path traversal vulnerability exists in the mlflow/mlflow repository due to improper handling of URL parameters. By smuggling path traversal sequences using the ';' character in URLs, attackers can manipulate the 'params' portion of the URL to gain unauthorized access to files or directories. This vulnerability allows for arbitrary data smuggling into the 'params' part of the URL, enabling attacks similar to those described in previous reports but utilizing the ';' character for parameter smuggling. Successful exploitation could lead to unauthorized information disclosure or server compromise.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2024-1593?

4 open source packages ship an affected version, including mlflow. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mlflow` | Bitnami | All versions | 2.11.3 |
| `mlflow` | PyPI | All versions to 2.9.2 | None |
| `mlflow` | PyPI | All versions to 2.9.2 | None |
| `mlflow` | PyPI | All versions to 2.9.2 | None |

Products: Lfprojects Mlflow.

## How do I fix CVE-2024-1593?

Upgrade mlflow to 2.11.3 or later.

## Is CVE-2024-1593 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-1593 exists.

## Other vulnerabilities in Lfprojects Mlflow

- [CVE-2026-64849](https://insights.sbomify.com/CVE-2026-64849/): MLflow Server-Side Request Forgery (critical 9.3, exploited in the wild)
- [CVE-2025-15379](https://insights.sbomify.com/CVE-2025-15379/): Command Injection in mlflow/mlflow (critical 10.0)
- [CVE-2024-0520](https://insights.sbomify.com/CVE-2024-0520/): Remote Code Execution due to Full Controlled File Write in mlflow/mlflow (critical 10.0)
- [CVE-2023-6977](https://insights.sbomify.com/CVE-2023-6977/): Path Traversal: '\..\filename' (critical 10.0)
- [CVE-2023-6709](https://insights.sbomify.com/CVE-2023-6709/): Improper Neutralization of Special Elements Used in a Template Engine in mlflow/mlflow (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-1593 and fix it if it is affected.

What it is: CVE-2024-1593 is a high-severity path traversal vulnerability in Lfprojects Mlflow, published on 16 Apr 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-1593 exists.

Affected packages and fixed versions:
- mlflow (Bitnami): affected all versions; fixed in 2.11.3
- mlflow (PyPI): affected all versions up to 2.9.2; no fix listed
- mlflow (PyPI): affected all versions up to 2.9.2; no fix listed
- mlflow (PyPI): affected all versions up to 2.9.2; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-1593/ (Markdown: https://insights.sbomify.com/CVE-2024-1593/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-1593
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-1593
- OSV: https://osv.dev/vulnerability/CVE-2024-1593

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-1593/
Summaries are generated and may contain mistakes; the official description above is the record.
